Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: update conflict

  1. #1

    Default update conflict

    Leap 42.3 but with extra repositories.

    I am totally confused, It says there is a conflict, then suggest a vendor change.

    I don think I want that, I want the stuff from packman. I switched all packages to packman in yast.



    These are my repositories:


  2. #2

    Default Re: update conflict

    mpg123 is not available on Packman anymore, as it is included in the distribution now (since 42.3) because the MP3 patents have expired.

    You apparently installed it from multimedia:libs though.

    The actual problem likely is that mpg123-esound doesn't exist anymore in multimedia:libs. I would recommend to uninstall it, esound has been dropped years ago anyway.

    Also, you maybe have a mixture of different package versions.
    What does "rpm -qa | grep mpg123" print?

    Also, your repo setup is likely to cause you problems at some point.
    multimedia:libs and multimedia:apps contain the latest multimedia packages, possibly even newer than Packman, so they would be preferred. But they are crippled of course.
    I would recommend to give Packman a higher priority (lower priority number) to force it to be preferred also for new packages.

    The vendor switch to Packman you did is a one-time action, that won't affect newly installed packages.

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,557

    Default Re: update conflict

    May I suggest the following:
    1. Lower the priority of the Packman repository: I tend to set Packman to a priority of at least 115.
    2. Lower the priority of the "home" repositories: my suggestion is to set them to a value of at least 130.
    3. Lower the priority of the Multimedia Apps and Multimedia Libs repositories: I tend to set such openSUSE repositories to a priority of at least 100 but, a higher priority than that of any non-openSUSE repositories.
    4. Lower the priority of the Google Chrome, Libdvdcss and Adobe Flash Player repositories: I tend to set such repositories to a priority less than that of any openSUSE repositories but, higher than the priority of the Packman repository.
    5. Do not change the system packages to the Packman repository.

    The version of libmpg123-0 in the openSUSE Multimedia Libs repository is newer than the one pointed to by the openSUSE-2017-1139 patch:
    • You may have to temporarily disable the Multimedia Apps and Multimedia Libs repositories to get the openSUSE-2017-1139 patch installed.


    AFAICS libmpg123 and mpg123-esound are not available from the Packman repository.


    On this Leap 42.3 system, mpg123-esound and libmpg123-0 are provided by openSUSE.
    The patch openSUSE-2017-1139 is installed:
    Code:
     > zypper patch-info openSUSE-2017-1139
    Loading repository data...
    Reading installed packages...
    
    
    Information for patch openSUSE-2017-1139:
    -----------------------------------------
    Repository  : Hauptaktualisierungs-Repository
    Name        : openSUSE-2017-1139             
    Version     : 1                              
    Arch        : noarch                         
    Vendor      : maint-coord@suse.de            
    Status      : applied                        
    Category    : security                       
    Severity    : moderate                       
    Created On  : Tue Oct 10 09:00:04 2017       
    Interactive : ---                            
    Summary     : Security update for mpg123     
    Description :                                
        This update for mpg123 to version 1.25.7 fixes the following issues:
    
        - CVE-2017-10683: Improvement over previous fix for xrpnt overflow problems (boo#1046766)
    
        The following changes are also included in version 1.25.7:
    
        - Do not play with cursor and inverse video for progress bar when TERM=dumb
        - Fix parsing of host port for numerical IPv6 addresses
    Provides    : patch:openSUSE-2017-1139 = 1   
    Conflicts   : [58]                           
        libmpg123-0.i586 < 1.25.7-10.1
        .
        .
        mpg123-esound.x86_64 < 1.25.7-10.1
        .
        .
    
     >

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,557

    Default Re: update conflict

    We seem to agree to disagree: my usual recommendation is to make sure that any non-openSUSE distribution repositories have a lower priority (higher priority number).
    I've broken my rule only once: with some KDE repositories …

  5. #5

    Default Re: update conflict

    Quote Originally Posted by dcurtisfra View Post
    May I suggest the following:
    1. Lower the priority of the Packman repository: I tend to set Packman to a priority of at least 115.
    But that would have the effect that the crippled openSUSE packages are preferred over Packman's.

    I would rather recommend the opposite, as I wrote.


    Do not change the system packages to the Packman repository.
    This is necessary to have full multimedia support.

    Please don't post such completely wrong advise.
    Or do you want to advocate the Fluendo codecs again?
    Won't help much with software not using gstreamer though.

    AFAICS libmpg123 and mpg123-esound are not available from the Packman repository.
    No, because they are included in the standard distribution now, as I wrote.
    The MP3 patents expired about a year ago, so there are no legal problems with shipping MP3 support anymore.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,557

    Default Re: update conflict

    Quote Originally Posted by wolfi323 View Post
    This is necessary to have full multimedia support.

    Please don't post such completely wrong advise.
    I read what you're saying and heed your request.

    Quote Originally Posted by wolfi323 View Post
    Or do you want to advocate the Fluendo codecs again?
    No. The Fluendo codecs are only interesting for MPEG > 3.

  7. #7

    Default Re: update conflict

    Quote Originally Posted by dcurtisfra View Post
    No. The Fluendo codecs are only interesting for MPEG > 3.
    There is also an MP3 codec by Fluendo.
    It even was/is shipped in openSUSE, in the non-oss repo.

    But as the MP3 patents expired, it's no longer necessary anyway, the standard gstreamer packages contain an MP3 plugin now as well (in gstreamer-plugins-ugly). That actually uses (lib)mpg123 for the decoding btw...

    Off-topic here anyway though, as this is about a problem with the official mpg123 update from openSUSE's Update repo.
    And that's a conflict between the standard repos and multimedia:libs (which contains the latest mpg123).
    Packman doesn't play a role here neither.
    Last edited by wolfi323; 14-Feb-2018 at 10:33.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,557

    Question Re: update conflict

    @Gps2010:
    From what you've described in your original Post, you had Leap 42.2 installed and have upgraded to Leap 42.3; two of the repository names need to be changed to reflect the current Leap 42.3 status quo but, that's a minor issue related to confusion.

    You also seem to be very dependent on the Multimedia repositories, possibly because the main openSUSE repositories possibly contain multimedia support which may be viewed as being "crippled".

    You don't need to explain why you need the openSUSE Multimedia repositories but, please be aware of this openSUSE Wiki statement: <https://en.opensuse.org/Restricted_formats>.
    There's also these Wiki pages: <https://en.opensuse.org/Concepts_multimedia>; <https://en.opensuse.org/Codecs>.

  9. #9

    Default Re: update conflict

    Quote Originally Posted by dcurtisfra View Post
    You also seem to be very dependent on the Multimedia repositories, possibly because the main openSUSE repositories possibly contain multimedia support which may be viewed as being "crippled".
    The packages in multimedia:libs and multimedia:apps are "crippled" too. These are actually the devel projects for the distribution.

    Only Packman contains the full versions.

  10. #10

    Default Re: update conflict

    Thank you guys.

    I removed esound, and that solved the update problem.

    I need to think, and maybe do a fresh install of leap 42.3. (not format home) and or disable the thumbleweed repository.


    I am having allot of issues all related to multimedia, because of me trying to compile a program myself.

    The program was lmms, and the compiling needs a lot of libs (and dev files)
    That was the reason why I added the thumbleweed repository, because I could not find the libs and dev files in the standard repositories.
    Compiling is not that hard, but in the case of lmms, you really need to install allot of extra stuff.

    All those extra libs, and dev files, keep causing me issues, and prob the fact my 42.3 is an update from 42.2, and the 42.2 was an update from 42.1.
    So I am dragging along allot of history.
    To some extent I am surprised it still works.

    For now I will give the thumbleweed repository a lower priority then the packman repository.

    ==================
    Going off topic:
    The good news for people who want to use LMMS, is that we don't need to compile it anymore.
    LMMS now has a file we can download and run. (appimage)

    This makes compiling release candidates myself, not necessary anymore.

    I do not know why there are so many problems with lmms.
    I do now its not just openSUSE, its every distro around.

    Maybe it has to do with wine? To load vst into lmms, you need wine.
    For some reason allot of the distro's give lmms with out vst support.

    I once talked with packman, and they admitted not really knowing lmms, so they need users like me (us) , to tell them if its not working as it should.
    Because I talked with packman, I found out the problem was with LMMS and not with openSUSE.

    For a reason beyond my understanding, lmms worked fine on 42.1, but not on 42.2 (and other distro's )
    That's why I started to compile it myself. The compiling it self did work out, I had the latest lmms running ( a release candidate), with vst support.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •