Results 1 to 3 of 3

Thread: Question about packman "switch system packages" -

  1. #1

    Default Question about packman "switch system packages" -

    Hi,

    1.

    I was about to do a zypper dup and there is one packman package that wants to do a system vendor change:

    Code:
    Problem: problem with installed package libvlccore8-2.2.8-5.10.x86_64
     Solution 1: install libvlccore8-2.2.8-2.3.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libvlccore8-2.2.8-5.10.x86_64
    I assume that VLC 3.0 is already in the TW repos, but this one package from packman is still at 2.2.8, therefore the conflict and requested vendor change?

    When I set up (just recently) my TW System I added packman, installed the codecs and then switched all system packages to packman. I also change the priorities as follows:

    Code:
    # | Alias                                  | Name                        | Enabled | GPG Check | Refresh | Priority
    --+----------------------------------------+-----------------------------+---------+-----------+---------+---------
    3 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository          | Yes     | (r ) Yes  | Yes     |   80    
    2 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   85    
    4 | repo-non-oss                           | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   90    
    5 | repo-oss                               | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   90    
    6 | repo-update                            | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   90    
    1 | http-download.opensuse.org-4ff6ea9f    | home:scarabeus_iv:mendeley  | Yes     | (r ) Yes  | Yes     |   99    
    7 | skype-stable                           | skype (stable)              | Yes     | (r ) Yes  | Yes     |   99    
    8 | skypeforlinux                          | skypeforlinux               | Yes     | (r ) Yes  | Yes     |   99
    So what should I do, allow vendor change for libvlccore8? Did I set something up the wrong way?

    2. Then I have another question about home repos. I know these are of course depended on the maintainer, in this case I added home:scarabeus_iv:mendeley, because I need mendeley and couldn't find it in the official repos. This maintainer seems to maintain quite a lot of packages, including Libreoffice, so I thought I could certainly trust this repo? Apart from not working (get an SSL certificate error when trying to login mendeley), is this ok to do in this case?

    How can I request this package to be added to packman?

    Thanks again,
    David

  2. #2

    Default Re: Question about packman "switch system packages" -

    Quote Originally Posted by SF6 View Post
    I assume that VLC 3.0 is already in the TW repos, but this one package from packman is still at 2.2.8, therefore the conflict and requested vendor change?
    Rather the opposite.
    Tumbleweed still has VLC 2.2.8, while Packman has 3.0 already.

    Btw, there is no conflict.
    zypper just asks you wheher you allow the vendor change, because the only available package comes from a different repo than it was installed from.

    If you don't have anything installed that requires libvlccore8, you could just as well uninstall it though.

    2. Then I have another question about home repos. I know these are of course depended on the maintainer, in this case I added home:scarabeus_iv:mendeley, because I need mendeley and couldn't find it in the official repos. This maintainer seems to maintain quite a lot of packages, including Libreoffice, so I thought I could certainly trust this repo? Apart from not working (get an SSL certificate error when trying to login mendeley), is this ok to do in this case?
    Sure, why not.

    How can I request this package to be added to packman?
    Ask on the Packman mailinglist...
    http://lists.links2linux.de/cgi-bin/...stinfo/packman

  3. #3

    Default Re: Question about packman "switch system packages" -

    Ah, got it.
    Since in the beginning I had all priorities at 99 VLC got pulled from OS. After setting the priorities for Packman one notch up and doing a zypper dup it wanted to upgrade to VLC 3.0 and all dependecies as well, but this one package is not in Packman, so it asked to switch to OS repo for that package (which no other program uses).

    What I did then is deinstall VLC and its dependecies using yast, and then reinstalling it since now it automatically pulls from Packman.

    Remember first thing to do after new OS install: Set repos And then zypper dup. And then start to install programs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •