Results 1 to 5 of 5

Thread: Grub splash screen removal

  1. #1
    Join Date
    Feb 2018
    Location
    East Tennessee, USA
    Posts
    6

    Question Grub splash screen removal

    I could not find grub customizer in YAST. Is there another way to get rid of the splash screens in booting up and shutting down?

    Quote Originally Posted by nrickert View Post
    I edit "/etc/default/grub" and the line for "GRUB_CMDLINE_LINUX_DEFAULT" by removing the string "splash=silent".

    Some people prefer to uninstall "plymouth". But if you use that method, you must lock it (or taboo it) after uninstalling, else it will be installed again.
    I tried the editing described above. No change. I installed* grub-customizer from https://software.opensuse.org/package/grub-customizer. It would not work because it could not find the command sh: grub-MK config

    * I did not allow updates from the repo to hopefully avoid future problems with updates.

  2. #2

    Default Re: Grub splash screen removal

    Quote Originally Posted by Tennessee_Coastie View Post
    I could not find grub customizer in YAST.
    Well, YaST only knows about and shows packages that are in one of your configured repositories.

    If you want to install packages not part of the distribution, you'd need to add a repo containing them first for them to show up in YaST.
    Those 1-click installs at software.opensuse.org automate that process though.

    Is there another way to get rid of the splash screens in booting up and shutting down?
    Sure.
    Uninstall plymouth, or add "plymouth.enabled=0" to the kernel boot options.

    I installed* grub-customizer from https://software.opensuse.org/package/grub-customizer. It would not work because it could not find the command sh: grub-MK config
    "Bug" in the package I'd say. The command is named "grub2-mkconfig" in openSUSE...
    Maybe contact the person who provides it.

    There are two listed though, maybe the other one would work.


    PS: Version 4.0.6 from home:ecsos should indeed work AFAICS, the other one misses the patch to use grub2-mkconfig instead of grub-mkconfig...
    Last edited by wolfi323; 13-Feb-2018 at 10:00.

  3. #3
    Join Date
    Feb 2018
    Location
    East Tennessee, USA
    Posts
    6

    Default Re: Grub splash screen removal

    Quote Originally Posted by wolfi323 View Post
    ... add "plymouth.enabled=0" to the kernel boot options. ...
    I like that option. It seems the simplest. I have looked in several places in YAST (Kernel Settings, Boot Loader, and /etc/sysconfig Editor) but can find a place to make this change.
    Left Mac OS X and Windows XP for Linux in January 2014

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: Grub splash screen removal

    Quote Originally Posted by Tennessee_Coastie View Post
    It would not work because it could not find the command sh: grub-MK config
    For openSUSE, use:
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    Possibly the command:
    Code:
    update-bootloader
    would also work.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: Grub splash screen removal

    Quote Originally Posted by Tennessee_Coastie View Post
    I like that option. It seems the simplest. I have looked in several places in YAST (Kernel Settings, Boot Loader, and /etc/sysconfig Editor) but can find a place to make this change.
    Go into YaST->Boot Loader and switch to the "Kernel Parameter" tab, you should see a text field labelled "Optional Kernel Boot Parameter" (or similar).

    Btw, I noticed I made a small typing mistake, it should be "plymouth.enable=0"...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •