Results 1 to 5 of 5

Thread: 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmail notworking)

  1. #1
    -G- NNTP User

    Default 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmail notworking)

    Hi I am running Leap 42.3 with a GeForce GTX970 nvidia card.
    All has been running fine (system kept constantly updated).

    Today came the update of the nvidia G04 driver version 390_25-4.1 and
    KMail and Kontact do not work anymore.

    They programs launch, but the Kmail or Kontact windows are never drawn
    (the window shows a the desktop buffer underneath it [icons, other open
    windows]). KOrganizer, however is fine.

    I removed the nvidia drivers (via Yast) and now I get a system with a
    very low resolution screen where I cannot do work with it (but tried and
    kmail works!).


    I reinstalled the system (in case it was something else). I get a low
    resolution screen (no nvidia driver), kmail works. Installed nvidia
    driver and kmail does not work anymore).

    Any suggestions?


    Question 1) Is there a way to revert to a previous version via Yast?
    (E.g. I have installed in a laptop version 384.111-3.1 and kmail still
    works, I am uneasy about updating that machine now).

    Question 2) if there is no way of installing an old version of the nvidia
    driver, how do I configure the system to use the nouveau driver instead
    and have a full resolution desktop?
    To reinstall 42.3 I had to insert the 'nomodeset' string at the opening
    installation menu because otherwise the screen would go blank and the
    installation fail to carry on.

    Many thanks for any insights.
    Cheers

    -G-


  2. #2
    -G- NNTP User

    Default Re: 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmail notworking)

    On Tue, 13 Feb 2018 11:57:17 +0000, I wrote:

    > Today came the update of the nvidia G04 driver version 390_25-4.1 and
    > KMail and Kontact do not work anymore.


    It seems that Kontact does not work because kmail and akregator have the
    issues, while the other Kontact components (KOrganizer, Addressbook, ToDo
    list and the Summary) seem to work fine).


    Cheers
    -G-


  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmail notworking)

    No can not revert from yast. You can get the driver from NVIDIA site and install the hard way that is what I have done.

    Removing the all the NVIDIA driver should revert to nouveau if you did not remove any of it's files

    Best to boot to a terminal rather then a GUI to do the install

  4. #4
    -G- NNTP User

    Default Re: 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmailnotworking)

    On Tue, 13 Feb 2018 22:56:02 +0000, gogalthorp wrote:
    > Removing the all the NVIDIA driver should revert to nouveau if you did
    > not remove any of it's files


    Thank you for your reply.
    I would happily stay with the nouveau driver, but it only sees 1024x768
    resolution (can't work with that, I have two 1920x1200 monitors that work
    (ed) fine with the nvidia driver.

    I installed 42.3 with the "nomodeset" flag (otherwise I get a black
    screen and cannot go further). That installation gives me a low
    resolution desktop.

    So my options are:
    unusable low resolution with a working kmail (nouveau)
    or
    full resolution with nvidia driver with unusable kmail.
    :-(

    I see that the problems with this version of the nvidia driver have been
    reported already:
    https://bugzilla.opensuse.org/show_bug.cgi?id=1080742

    I also just tried the zypper installation suggested in the bugzilla
    thread, but the situation is the same (no working kmail or akregator),
    which tells me that I did not have an installation problem, but I am
    seeing some other bug in the driver.

    Thanks again
    -G-

  5. #5
    -G- NNTP User

    Default Re: 42.3 & nvidia driver 390_25-4.1 disastrous update (Kmailnotworking)

    I have found a workaround.
    I added myself to the video group. That makes kmail work again.
    It might not be the ideal solution but it resolves the issue for now.

    -G-


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •