Results 1 to 2 of 2

Thread: lamp_server-Pattern mit PHP5 statt PHP7

  1. #1

    Default lamp_server-Pattern mit PHP5 statt PHP7

    Hallo,

    gerade wollte ich das lamp_server-Pattern zur Installation verwenden, und da sehe ich, dass die langsame PHP-Version 5 verwendet wird statt die 7er Version.
    Kann ich PHP5 nach der Installation durch PHP7 ersetzen?
    Worin genau besteht der Vorteil das lamp_server-Pattern zu nutzen statt apache2, PHP7, MySQL/MariaDB einzeln zu installieren, dass ich also nur einmal "zypper in -t pattern lamp_server" eingeben muss statt 4 Programme einzeln zu installieren?

    Grüße

    Code:
    $ zypper info -t pattern lamp_server
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    
    Informationen zu Schema lamp_server:
    ------------------------------------
    Repository                : openSUSE-Leap-42.3-0
    Name                      : lamp_server         
    Version                   : 20170518-6.1        
    Arch                      : x86_64              
    Anbieter                  : openSUSE            
    Installiert               : Nein                
    Sichtbar für den Benutzer : Ja                  
    Zusammenfassung           : Web- und LAMP-Server
    Beschreibung              :                     
        Sie können einen Webserver einrichten, der für statische, dynamische und interaktive Inhalte geeignet ist (wie zum Beispiel ein Web-Shop). Er
        beruht auf dem Apache-HTTP-Server, dem Datenbankverwaltungssystem MySQL und einer Skriptsprache wie PHP, Python, Ruby on Rails oder Perl.
    Inhalt                    :                     
        S  | Name                          | Typ     | Abhängigkeit
        ---+-------------------------------+---------+-------------
        i+ | patterns-openSUSE-base        | package | Benötigt
           | patterns-openSUSE-lamp_server | package | Benötigt
           | apache2                       | package | Empfohlen
           | apache2-doc                   | package | Empfohlen
           | apache2-example-pages         | package | Empfohlen
           | apache2-mod_perl              | package | Empfohlen
           | apache2-mod_php5              | package | Empfohlen
           | apache2-mod_python            | package | Empfohlen
           | apache2-prefork               | package | Empfohlen
        i  | mariadb                       | package | Empfohlen
           | php5-ctype                    | package | Empfohlen
           | php5-dom                      | package | Empfohlen
           | php5-iconv                    | package | Empfohlen
           | php5-mysql                    | package | Empfohlen
           | yast2-http-server             | package | Empfohlen

  2. #2

    Default Re: lamp_server-Pattern mit PHP5 statt PHP7

    Quote Originally Posted by Duplexity View Post
    gerade wollte ich das lamp_server-Pattern zur Installation verwenden, und da sehe ich, dass die langsame PHP-Version 5 verwendet wird statt die 7er Version.
    Tja, Leap 42.3 kommt halt mit php5 als Default.
    Wird sich sicher in einer der nächsten Versionen ändern. (weiß jetzt nicht auswendig wies bei 15.0 sein wird)

    Kann ich PHP5 nach der Installation durch PHP7 ersetzen?
    Sollte möglich sein, solange nicht irgendwas anderes PHP5 vorraussetzt...

    Worin genau besteht der Vorteil das lamp_server-Pattern zu nutzen statt apache2, PHP7, MySQL/MariaDB einzeln zu installieren, dass ich also nur einmal "zypper in -t pattern lamp_server" eingeben muss statt 4 Programme einzeln zu installieren?
    Die *einzige* Funktion eines Patterns ist es eine vorgefertigte Auswahl an Paketen zu installieren.
    D.h. du kannst die Pakete die du brauchst genausogut einzeln installieren.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •