Results 1 to 4 of 4

Thread: Dolphin automatically mount NFS share

  1. #1

    Default Dolphin automatically mount NFS share

    I have my laptop configured as NFS-client that I can mount the home directory of my main computer for data exchange. I've put the options "noauto" and "user" to the fstab. Now when I startup the laptop and the main computer is running, Dolphin automatically mounts this share. How can I stop this behavior? I is annoying since when I forgot to unmount it before shutdown, it will block the computer during shut down for over 90 seconds ("A stop job is running for /NAS...").

    Thanks in advance.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Dolphin automatically mount NFS share

    I do not know about the NFS shared folder.
    I configure our laptops to use ssh/sftp for users to access their office home documents when out of the office.

    Set up an ssh connection from the laptop to the office desktop

    copy laptop:~/.ssh/id_rsa.pub
    into office:~/authorized_keys
    if necessary use ssh-keygen in Konsole to generate a key pair and use and create an authorized_keys file on the office machine.
    Make sure that sshd.service is enabled and that the appropriate TCP/IP port is open.

    On the laptop in dolphin right-click on “Places” and select add entry.
    One of mine to connect to a remote machine with the network address “ns3” (defined in the laptop's “/etc/hosts” file, but also on our DNS servers):
    Label: ns3-docs
    Location: sftp://rayh@ns3:9322/home/sysman/Documents/
    (we are using port 9322 for ssh on ns3).

    This creates a Dolphin Place called “ns3-docs” that can be left-clicked on to switch the current pane to the remote Documents folder, or right-clicked on to open in a new window or tab. No need for fstab entries and it can work from anywhere wit network access.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Dolphin automatically mount NFS share

    Quote Originally Posted by hkottmann View Post
    I have my laptop configured as NFS-client that I can mount the home directory of my main computer for data exchange. I've put the options "noauto" and "user" to the fstab. Now when I startup the laptop and the main computer is running, Dolphin automatically mounts this share. How can I stop this behavior? I is annoying since when I forgot to unmount it before shutdown, it will block the computer during shut down for over 90 seconds ("A stop job is running for /NAS...").

    Thanks in advance.
    My recommendation is to remove the ftsab entry and instead use AutoFS to handle the mounting. The directory will automatically be unmounted if the directory is not accessed for the timeout period specified .

    https://doc.opensuse.org/documentati...sec.autofs.nfs

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Dolphin automatically mount NFS share

    options soft,noauto,users 0 0 work here. Note the s in users, check man page and IINM you'll see why.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •