Results 1 to 5 of 5

Thread: Prevent Automatic Software Updates / ksmserver-logout-greeter Error

  1. #1

    Default Prevent Automatic Software Updates / ksmserver-logout-greeter Error

    1. How to prevent Automatic Software Updates: I have an old repurposed Lenovo G550 laptop (old Intel Core 2 Duo T6600 CPU), ran miserably under WinXP but thinks it's a fresh pup under Tumbleweed. I'm giving it to a friend who has a very tight budget - even piggybacking/cost-sharing a neighbor's WiFi. Unfortunately, when this laptop powers up, it immediately wants to check for S/W updates (it's set to Monthly frequency). The laptop is a bit laggy in activating its WiFi, and so the auto S/W update check always returns an update error. I have no problems getting the WiFi activated, but my friend is a certified technophobe, and I'm certain she would have difficulties with this.

    So, question: How can I prevent the automatic software update check at bootup? I don't want any automatic checking - I'll periodically drop by her house and manually update it myself.

    2. Prior to the update to Plasma 5.12 final, I was experiencing the ksmserver-logout-error problem on all in-house machines. The three AMD systems are now working okay, but the give-away Lenovo laptop (perhaps not so oddly because it has an Intel CPU ???) still has the problem, causing me to back out the 20180207 update incorporating the 4.15.1 kernel as well as Plasma 5.12 final among many others.

    I saw Knurpht's response to this (Thread: after update plasmashell and many KDE apps black), and am going to try deleting the two /cache folders as he outlined. Hopefully that'll resolve the problem on the Lenovo, too.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,803

    Default Re: Prevent Automatic Software Updates / ksmserver-logout-greeter Error

    Remove the updater. only use zypper dup.when you want updated. It is just a notifier and yes it runs at each GUI start and should not be relied upon in Tumbleweed since it is a roll distro

    Second option start Networkmanger earlier by setting allow all users check box in settings. This will start NM at boot rather then GUI start

  3. #3

    Default Re: Prevent Automatic Software Updates / ksmserver-logout-greeter Error

    Since you refer to plasma, I guess you want the updater applet killed, right? A rather brutal method I use on all computers is

    Code:
    sudo zypper rm plasma5-pk-updates
    sudo zypper al plasma5-pk-updates
    First line removes the applet package, second line locks it so it will not get installed again.

    The graphics problem showing black screen with cursor happened *again* today. So I added a script that deletes the offending .cache/qt* entries on logout. Just create a script in, say, ~/bin/scripts/99-rm-cache.sh. Then go to plasma systemsettings > startup > autostart > add script, choose the script, set to 'on logout', done. I use that logout script feature quite extensively for various cleanup tasks.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,189
    Blog Entries
    3

    Default Re: Prevent Automatic Software Updates / ksmserver-logout-greeter Error

    You can right-click on tray, and select "System Tray Settings". Uncheck the box for the updater.

    That's all you need to do.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Prevent Automatic Software Updates / ksmserver-logout-greeter Error

    ... but, if giving it to a "technophobe", I would install 42.3, not Tumbleweed.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •