Results 1 to 5 of 5

Thread: broken SDDM again

  1. #1
    Join Date
    Sep 2017
    Location
    Melbourne, Australia
    Posts
    36

    Default broken SDDM again

    Hello everyone,

    I also zypper dup'd the mesa problem the other day and just as quickly solved the problem by rolling back with snapper and removing ~.cache and /var/lib/sddm/.cache directories. Then this morning I started up and did my usual zypper dup and received the following...

    Code:
     zdup                  
    [sudo] password for root: 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    The following 11 packages are going to be downgraded:
      libgbm1 libvdpau_nouveau libwayland-egl1 Mesa Mesa-dri Mesa-dri-nouveau Mesa-gallium
      Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 Mesa-libva
    
    11 packages to downgrade.
    Overall download size: 19.3 MiB. Already cached: 0 B. After the operation, 9.6 MiB will be freed.
    Continue? [y/n/...? shows all options] (y):
    So thinking that this was just another update for the Mesa packages I went ahead and after reboot SDDM was broken again. I recovered again by snapper rollback and removing ~/.cache and /var/lib/sddm/.cache again..

    I'm just a little concerned that this isn't fully resolved and will arise again the next time I zypper dup?

    Here are my repos

    Code:
     zypper lr
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                               | Name               | Enabled | GPG Check | Refresh
    ---+-------------------------------------+--------------------+---------+-----------+--------
     1 | fonts                               | fonts              | Yes     | (r ) Yes  | Yes    
     2 | games                               | games              | Yes     | (r ) Yes  | Yes    
     3 | http-download.opensuse.org-370efad8 | X11:windowmanagers | Yes     | (r ) Yes  | Yes    
     4 | http-download.opensuse.org-4f25f6ea | home:mrbadguy      | Yes     | (r ) Yes  | Yes    
     5 | http-download.opensuse.org-a0fd9cb6 | security:privacy   | Yes     | (r ) Yes  | Yes    
     6 | http-download.opensuse.org-e05a7884 | home:syntobu       | Yes     | (r ) Yes  | Yes    
     7 | http-download.opensuse.org-ee33a03c | games:tools        | Yes     | (r ) Yes  | Yes    
     8 | namtracfont                         | namtracfont        | Yes     | (r ) Yes  | Yes    
     9 | packman                             | packman            | Yes     | (r ) Yes  | Yes    
    10 | repo-debug                          | repo-debug         | Yes     | (r ) Yes  | Yes    
    11 | repo-non-oss                        | repo-non-oss       | Yes     | (r ) Yes  | Yes    
    12 | repo-oss                            | repo-oss           | Yes     | (r ) Yes  | Yes    
    13 | repo-src-non-oss                    | repo-src-non-oss   | No      | ----      | ----   
    14 | repo-src-oss                        | repo-src-oss       | No      | ----      | ----   
    15 | repo-update                         | repo-update        | Yes     | (r ) Yes  | Yes
    and my system..
    Code:
    inxi -v2
    System:    Host: t420 Kernel: 4.15.1-1-default x86_64 bits: 64 Desktop: KDE Plasma 5.12.0
               Distro: openSUSE Tumbleweed 20180207
    Machine:   Device: laptop System: LENOVO product: 4180RQ8 v: ThinkPad T420 serial: N/A
               Mobo: LENOVO model: 4180RQ8 serial: N/A UEFI [Legacy]: LENOVO v: 83ET79WW (1.49 ) date: 09/05/2016
    Battery    BAT0: charge: 38.7 Wh 99.6% condition: 38.9/56.2 Wh (69%)
    CPU:       Dual core Intel Core i5-2520M (-MT-MCP-) speed/max: 818/3200 MHz
    Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
               Card-2: NVIDIA GF119M [Quadro NVS 4200M]
               Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nouveau (unloaded: fbdev,vesa)
               Resolution: 1600x900@60.01hz
               OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile version: 3.3 Mesa 18.0.0-rc3
    Network:   Card-1: Intel 82579LM Gigabit Network Connection (Lewisville) driver: e1000e
               Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    Drives:    HDD Total Size: 240.1GB (9.2% used)
               ID-1: model: SanDisk_SDSSDA24
    Info:      Processes: 220 Uptime: 0:20 Memory: 1439.4/7754.6MB Client: Shell (zsh) inxi: 2.3.56
    any advice or direction will be appreciated.

    Regards
    Tim Freedman
    Lenovo t420 tumbleweed x86_64 GNU/Linux

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: broken SDDM again

    Again, remove /var/lib/sddm/.cache and your user's ~/.cache
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Sep 2017
    Location
    Melbourne, Australia
    Posts
    36

    Default Re: broken SDDM again

    Quote Originally Posted by Knurpht View Post
    Again, remove /var/lib/sddm/.cache and your user's ~/.cache

    I have done that Knurpht, I'm just curious as to why zypper dup is trying to revert those Mesa packages?
    Tim Freedman
    Lenovo t420 tumbleweed x86_64 GNU/Linux

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: broken SDDM again

    Quote Originally Posted by tim3dman View Post
    I have done that Knurpht, I'm just curious as to why zypper dup is trying to revert those Mesa packages?
    It's probably in the spec file, as a requirement
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: broken SDDM again

    No login, then after rebooting a blackscreen with a tiny bar at the top left corner. After I tabooed the SDDM packages, all is fine with me . Loggin into Leap 42.3, I got a hint: Ctrl+Alt+F2. Apparently, SDDM is installed as the default display manger (it got installed after I had deleted it). I am probably using KDM (KDM, XDM, lightdm are installed on the system).

    SDDM seemed to interfere with some window managers (awesome, notion, ratpoison, Pekwm), too, even when it allowed me to log in to Plasma, Fluxbox, Openbox, IceWM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •