Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

  1. #1

    Default XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Hi everybody!

    General setup: 1x Raspberry Pi 3 wtih two additional USB-RJ45 adaptors, latest Tumbleweed XFCE with updates from yesterday, bridge-utils and Wireshark installed.

    I bridge the two USB-RJ45 devices with the following:

    Code:
    ifconfig eth1 -arp promisc 0.0.0.0 up 
    ifconfig eth2 -arp promisc 0.0.0.0 up 
    brctl addbr br0 
    brctl addif br0 eth1 
    brctl addif br0 eth2 
    ifconfig br0 -arp promisc 0.0.0.0 up
    ...and start Wireshark on the bridge interface. Normally there should be silence on the bridge, as long as no traffic is coming from the clients (on one USB-RJ45 interface: router interface, other USB-RJ45: Win10 PC without any power, i.e. power plug pulled).

    However, on the USB-RJ45 connected to the totally dead I get:

    Code:
    1    0.000000000    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    again, and again and again.

    I tried Wicked (IPv6 disabled) -> same result

    I tried NetworkManager (IPv6 "Ignored" on all three interfaces) -> same result

    I disabled anything related to Avahi in Yast -> ServiceManager

    Interestingly, when I use Tumbleweed JeOS with Enlightenment desktop on the same Raspi with the same USB-RJ45 interfaces, it's totally silent.

    Where to look next? What is sending out IPv6 ICMP?

    What could I disable/uninstall to make the bridge silent?

    Many thanks in advance.
    Kind regards

    raspu

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Hi
    The USB interface, I'm guessing the asix driver...

    Code:
    00:0E:C6 ASIX ELECTRONICS CORP.
    The windows box has W.o.L active perhaps (check BIOS)?

    How long did you observe/monitor on each of the two different desktops?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Hy!

    I found in the meantime:

    Code:
    ifconfig
    br0: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            inet6 fe80::20e:c6ff:fec6:6697  prefixlen 64  scopeid 0x20<link>
            ether 00:0e:c6:c6:66:97  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 15  bytes 1050 (1.0 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    ....
    So the BRIDGE actually has "inherited" the IPv6 address of one of the members. How to change this?

    I can set in NetworkManager IPv6 to "Ignored" for the bridge, but it doesn't change anything in the output of ifconfig.

    WOL might be active, but as I said, the machine is not plugged in to any power.

    Observation periods:

    With JeOS+Enlightenment: For hours and hours. -> Nothing like that

    With TW XFCE: for some hours now -> ICMPv6 comes back again and again:

    Code:
    1    0.000000000    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    2    3.866352499    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    3    11.626367496    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    4    27.626359469    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    5    58.986364509    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    6    124.906360786    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    7    1189581.814170311    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    ...
    15    1208157.103065335    fe80::20e:c6ff:fec6:6697    ff02::2    ICMPv6    70    Router Solicitation from 00:0e:c6:c6:66:97
    Kind regards

    raspu

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Hi
    If you down/up the bridge does it disappear? IPv6 is disabled in /etc/sysctl.conf?
    Code:
    net.ipv6.conf.all.disable_ipv6 = 1
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    I have in /etc/sysctl.conf

    Code:
    ####
    #
    # /etc/sysctl.conf is meant for local sysctl settings
    #
    # sysctl reads settings from the following locations:
    #   /boot/sysctl.conf-<kernelversion>
    #   /lib/sysctl.d/*.conf
    #   /usr/lib/sysctl.d/*.conf
    #   /usr/local/lib/sysctl.d/*.conf
    #   /etc/sysctl.d/*.conf
    #   /run/sysctl.d/*.conf
    #   /etc/sysctl.conf
    #
    # To disable or override a distribution provided file just place a
    # file with the same name in /etc/sysctl.d/
    #
    # See sysctl.conf(5), sysctl.d(5) and sysctl(8) for more information
    #
    ####
    
    net.ipv6.conf.all.disable_ipv6 = 1
    I tried several reboots, every time the same again.

    I just found on the br0 "Bridge" tab in the NetworkManager app that

    Code:
    "Enable IGMP snooping"
    is checked. Is that of any relevance? But I want to get rid of the IPv6 adress for the bridge COMPLETELY.

    How to do that? IPv6 is turned of everywhere, but comes up like a pest again and again...
    Kind regards

    raspu

  6. #6

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    ... I tried on the Raspi 3 with TW JeOS and Enlightenment, set up the bridge as described above and get:

    Code:
    ifconfig
    br0: flags=4483<UP,BROADCAST,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:cc:f9:bd  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    So no IPv6 on the bridge here...
    Kind regards

    raspu

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Quote Originally Posted by suse_rasputin View Post
    I have in /etc/sysctl.conf

    Code:
    ####
    #
    # /etc/sysctl.conf is meant for local sysctl settings
    #
    # sysctl reads settings from the following locations:
    #   /boot/sysctl.conf-<kernelversion>
    #   /lib/sysctl.d/*.conf
    #   /usr/lib/sysctl.d/*.conf
    #   /usr/local/lib/sysctl.d/*.conf
    #   /etc/sysctl.d/*.conf
    #   /run/sysctl.d/*.conf
    #   /etc/sysctl.conf
    #
    # To disable or override a distribution provided file just place a
    # file with the same name in /etc/sysctl.d/
    #
    # See sysctl.conf(5), sysctl.d(5) and sysctl(8) for more information
    #
    ####
    
    net.ipv6.conf.all.disable_ipv6 = 1
    I tried several reboots, every time the same again.

    I just found on the br0 "Bridge" tab in the NetworkManager app that

    Code:
    "Enable IGMP snooping"
    is checked. Is that of any relevance? But I want to get rid of the IPv6 adress for the bridge COMPLETELY.

    How to do that? IPv6 is turned of everywhere, but comes up like a pest again and again...
    Hi
    Some info here;
    https://routerguide.net/enable-igmp-snooping-on-or-off/

    Delete the bridge, swap adapters across different USB ports and create the bridge again, does it follow the device.

    No ipv6 in the output from the arp command?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    I switched to Wicked, set all three interfaces to IPv4 DHCP and rebooted. After establishing the bridge, the IPv6 was gone for the bridge in ifconfig

    Code:
    ifconfig
    br0: flags=4483<UP,BROADCAST,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:c6:66:97  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    , but after adding the patch cables, the IPv6 on bridge was back.

    Code:
    ifconfig
    br0: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            inet6 fe80::20e:c6ff:fec6:6697  prefixlen 64  scopeid 0x20<link>
            ether 00:0e:c6:c6:66:97  txqueuelen 1000  (Ethernet)
            RX packets 4  bytes 1030 (1.0 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 3  bytes 210 (210.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    Unbelievable.

    Added the same cables to the two USB-RJ45 on the TW JeOS + Enlightenment: No IPv6 comming up in ifconfig:

    Code:
     ifconfig
    br0: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:cc:f9:bd  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    Kind regards

    raspu

  9. #9

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    Nope, with arp I only get info on IPv4, on both raspis....

    Now with Wicked I get an IPv4 IP-address offered from my router for the MAC of one of the USB-RJ45's in the bridge:

    Code:
    1    0.000000000    IntelCor_xx:yy:zz    Broadcast    ARP    60    Who has 192.168.123.2? Tell 192.168.123.1
    
    2    1.029762187    192.168.123.1    192.168.123.2    DHCP    342    DHCP Offer    - Transaction ID 0xf9e6e74f
    3    3.849994998    192.168.123.1    192.168.123.2    DHCP    342    DHCP Offer    - Transaction ID 0xf9e6e74f
    ...
    I have seen something like that in Raspbian (light with XFCE desktop), but never before with any TW (raspi 2 or 3) I used in the past.
    Kind regards

    raspu

  10. #10

    Default Re: XFCE for Raspi 3 - ICMPv6 chatter on bridge interface

    I found a difference between the TW XFCE and the TW JeOS+Enlight.

    In TW XFCE the FIRST (eth1) member of the bridge is running and provides the MAC fro the bridge:

    Code:
    ifconfig
    br0: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            inet6 fe80::20e:c6ff:fec6:6697  prefixlen 64  scopeid 0x20<link>
            ether 00:0e:c6:c6:66:97  txqueuelen 1000  (Ethernet)
            RX packets 28  bytes 8620 (8.4 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 5  bytes 350 (350.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet ...
    
    eth1: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:c6:66:97  txqueuelen 1000  (Ethernet)
            RX packets 21  bytes 6606 (6.4 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 20  bytes 6920 (6.7 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eth2: flags=4483<UP,BROADCAST,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:c6:68:ab  txqueuelen 1000  (Ethernet)
            RX packets 7  bytes 2014 (1.9 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 11  bytes 2446 (2.3 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    While in TW JeOS+ Enlight the SECOND (eth2) is Running, but the first member (eth1) provides the MAC:

    Code:
     ifconfig
    br0: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:cc:f9:bd  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet ...
    
    eth1: flags=4483<UP,BROADCAST,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:cc:f9:bd  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eth2: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 1500
            ether 00:0e:c6:cc:fc:b3  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    Kind regards

    raspu

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •