Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: qgis not launching

  1. #1

    Default qgis not launching

    Hi, I am unable to launch qgis on OpenSuse Leap 42.3

    Version
    Repositório : Applications related to the earth (GIS, Mapping, geodesy, GPS, astronomy) (openSUSE_Leap_42.3)
    Nome : qgis
    Versão : 2.18.16-1.6
    Arquitetura : x86_64
    Fornecedor : obs://build.opensuse.org/Application:Geo
    Tamanho após instalação : 207,2 MiB
    Instalado : Sim
    Status : atualizado
    Pacote fonte : qgis-2.18.16-1.6.src
    Resumo : QGIS is a Geographic Information System (GIS)
    Descrição :
    QGIS is a user friendly Open Source Geographic Information System (GIS)
    that runs on Linux, Unix, Mac OSX, and Windows. QGIS supports vector,
    raster, OWS and database formats. QGIS is licensed under the GNU
    General Public License. QGIS lets you browse and create map data on your
    computer. It supports many common spatial data formats (e.g. ESRI ShapeFile,
    geotiff). QGIS supports plugins to do things like display tracks from your GPS.

    Last output when I run from terminal:

    src/core/qgsproviderregistry.cpp: 201: (init) [0ms] Checking /usr/lib64/qgis/libogrprovider.so: ...loaded ok (43 file filters)
    src/core/qgsproviderregistry.cpp: 134: (init) [1ms] Checking /usr/lib64/qgis/liboracleplugin.so: ...invalid (has type method)
    src/core/qgsproviderregistry.cpp: 142: (init) [0ms] Checking /usr/lib64/qgis/libpkcs12authmethod.so: ...invalid (no isProvider method)
    src/core/qgsproviderregistry.cpp: 142: (init) [0ms] Checking /usr/lib64/qgis/libpkipathsauthmethod.so: ...invalid (no isProvider method)
    src/core/qgsproviderregistry.cpp: 134: (init) [2ms] Checking /usr/lib64/qgis/librasterterrainplugin.so: ...invalid (has type method)
    src/core/qgsproviderregistry.cpp: 134: (init) [1ms] Checking /usr/lib64/qgis/libroadgraphplugin.so: ...invalid (has type method)
    src/core/qgsproviderregistry.cpp: 134: (init) [1ms] Checking /usr/lib64/qgis/libspatialqueryplugin.so: ...invalid (has type method)
    src/core/qgsproviderregistry.cpp: 134: (init) [0ms] Checking /usr/lib64/qgis/libtopolplugin.so: ...invalid (has type method)
    src/providers/wfs/qgswfsutils.cpp: 212: (init) [3ms] Keep-alive mechanism works
    src/core/qgsproviderregistry.cpp: 134: (init) [2ms] Checking /usr/lib64/qgis/libzonalstatisticsplugin.so: ...invalid (has type method)
    src/app/qgisapp.cpp: 8868: (loadPythonSupport) [0ms] load library /usr/lib64/qgispython (2.18.16)
    Segmentation failure (core image recorded)

    Do you have any clue? Thanx


  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: qgis not launching

    Try re-installing with the following command,
    If the following results in an error or, post...
    Code:
    zypper in -f qgis
    Then try re-launching qgis and let us know if you see the same error.

    Also,
    When you post anything that is displayed in your console, like the package information and the error stdout, you should enclose in [CODE] tags, by clicking on the Hash button(#).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: qgis not launching

    Thanx for helping,
    I did that but the problem persists with the same messages in terminal.

  4. #4

    Default Re: qgis not launching

    I have QGIS 2.18.15 in Tumbleweed. It works.
    Try to start with a fresh profile (ie move ~/.qgis2 to ~/.qgis2.sv

  5. #5

    Default Re: qgis not launching

    Tryed that also, but the message is the same...

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: qgis not launching

    I suspect your Geo repo might be incorrect.

    I'm also pretty sure you installed the source for your qgis application and not the application itself... And then my guess is that whatever you're doing might be to compile the app.

    You should instead install the pre-compiled qgis app.

    But, first I recommend you list your repositories with the following command.
    You can list your configured repositories displaying their URI with the following command
    Code:
    zypper lr -d
    If you don't know if your current geo repo is correct, then you should remove it with the following command where "repo_id" can be the repo name or repo number when you listed it (the above command)
    Code:
    zypper rr repo_id
    I can't be sure that your obs URI matches the correct repository, instead of obs:// your repository should have the following (the entire link and not the shortened link which is displayed)

    https://download.opensuse.org/reposi...USE_Leap_42.3/

    Using the above,
    You can install the repo with the following command
    Code:
    zypper ar -f https://download.opensuse.org/repositories/Application:/Geo/openSUSE_Leap_42.3/ 42.3_Geo
    After the above, you can refresh your repos with the following command
    Code:
    zypper ref
    Followed by installing qgis
    Code:
    zypper in qgis
    Following the above steps, you should be able to launch qgis without any error.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: qgis not launching

    I did a fresh reinstall (of the distribution) but it did not worked either.
    First it appeared some certificates things in a first launch, but now it went back to the same message...

  8. #8

    Default Re: qgis not launching

    Try to do a full switch to that repo, as explained here:
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change

    Maybe the crash is caused by different library versions on your system and against which qgis is built.

  9. #9

    Default Re: qgis not launching

    Yeah, tried that but did not work. This is my list of repositorys.
    Code:
    #  | Apelido                    | Nome                                                     | Habilitado | Verificação GPG | Atualizar | Prioridade 
    ---+----------------------------+----------------------------------------------------------+------------+-----------------+-----------+----------- 
    18 | Packman_Leap-42.3          | Packman_Leap-42.3                                        | Sim        | (r ) Sim        | Sim       |   90
    8 | KDE-Applications-Leap-42.3 | KDE-Applications-Leap-42.3                               | Sim        | (r ) Sim        | Sim       |   96
    9 | KDE-Extra-Leap-42.3        | KDE-Extra-Leap-42.3                                      | Sim        | (r ) Sim        | Sim       |   96
    10 | KDE-Frameworks5-Leap-42.3  | KDE-Frameworks5-Leap-42.3                                | Sim        | (r ) Sim        | Sim       |   96
    11 | KDE-Qt5-Leap-42.2          | KDE-Qt5-Leap-42.2                                        | Sim        | (r ) Sim        | Sim       |   96
    2 | Application_Geo            | Application_Geo                                          | Sim        | (r ) Sim        | Sim       |   99       
    3 | Arc_Papirus                | Arc_Papirus                                              | Sim        | (r ) Sim        | Sim       |   99       
    6 | Google-chrome              | Google-chrome                                            | Sim        | (r ) Sim        | Sim       |   99       
    7 | Google-talkplugin          | Google-talkplugin                                        | Sim        | (r ) Sim        | Sim       |   99       
    19 | Printing                   | Printing System Development Project (openSUSE_Leap_42.3) | Sim        | (r ) Sim        | Sim       |   99       
    20 | R_devel                    | R_devel                                                  | Sim        | (r ) Sim        | Sim       |   99       
    22 | google-chrome              | google-chrome                                            | Sim        | (r ) Sim        | Sim       |   99       
    23 | opera                      | Opera packages                                           | Sim        | (r ) Sim        | Sim       |   99       
    13 | Leap-42.3_OSS_updates      | Leap-42.3_OSS_updates                                    | Sim        | (r ) Sim        | Sim       |  100
    15 | Leap-42.3_non-OSS_updates  | Leap-42.3_non-OSS_updates                                | Sim        | (r ) Sim        | Sim       |  100
    12 | Leap-42.3_OSS              | Leap-42.3_OSS                                            | Sim        | (r ) Sim        | Sim       |  101
    14 | Leap-42.3_non-OSS          | Leap-42.3_non-OSS                                        | Sim        | (r ) Sim        | Sim       |  101
    1 | Albert                     | Albert                                                   | Sim        | (r ) Sim        | Sim       |  115
    4 | Education                  | Education                                                | Não        | ----            | ----      |  115
    5 | GnomeEncfs                 | GnomeEncfs                                               | Sim        | (r ) Sim        | Sim       |  115
    16 | Mendeley                   | Mendeley                                                 | Sim        | (r ) Sim        | Sim       |  115
    17 | Nvidia                     | Nvidia                                                   | Não        | ----            | ----      |  115
    21 | code                       | Visual Studio Code                                       | Sim        | (r ) Sim        | Não       |  115
    24 | skype-stable               | Skype                                                    | Sim        | (r ) Sim        | Sim       |  115

    Quote Originally Posted by wolfi323 View Post
    Try to do a full switch to that repo, as explained here:
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change

    Maybe the crash is caused by different library versions on your system and against which qgis is built.


  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: qgis not launching

    Please re-post your repos using the "-d" flag which displays entries "with detail."
    Can't know the true location of each repos otherwise

    ie
    Code:
    zypper lr -d
    And,
    Are you sure even after re-install your entire system that the error is exactly the same?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •