Results 1 to 2 of 2

Thread: DSpace: Solr webapp shows “UnknownHostException”

  1. #1

    Default DSpace: Solr webapp shows “UnknownHostException”

    Hi,

    I'm trying to set up a DSpace 5.4 on a local VM to prepare for the upgrade to DSpace 5.5 on another machine.


    The setup procedure works fine, but I can't get the Apache solr webapp to work. I deployed it (Using Tomocat 8.0.33 and OpenJDK 1.8.0_60 on OpenSuse Leaf 42.1), and it's returning the following error when called from the VM and from the host:


    java.net.UnknownHostException: linux-ai1n: unknown error
    java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
    java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928)
    java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323)
    java.net.InetAddress.getLocalHost(InetAddress.java:1500)
    org.dspace.solr.filters.LocalHostRestrictionFilter.doFilter(LocalHostRestrictionFilter.java:38)
    So when using a discovery related function, this error is returned:


    Expected mime type application/octet-stream but got text/html.
    Answers I found only suggest to change the solr URL, so I have tried changing the solr URL in config/modules/discovery.cfg from http://localhost:8080/solr/search to http://127.0.0.1:8008/solr/search, but that did not solve the problem.


    Any hints what to check next would be very helpful. Could this be an issue with not enough memory available on the virtual machine?


    Thank you

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: DSpace: Solr webapp shows “UnknownHostException”

    I suspect...

    Your solr is installed bound to your network address, which would be different than your localhost address.
    In any case, it looks like it's likely that your solr app may be using name resolution so you should be able to overcome whatever network address solr is bound to, by creating an appropriate mapping in your /etc/hosts file (supporting the hostname in your solr config file).

    Big data apps like Lucene and solr are pretty specialized,
    I suspect that you won't likely find many if anyone familiar with the app(s) here... I myself only have a passing exposure to it because I specialize in the solr/pig/hive stack's competitor, elastic.

    Looks like the reference for your config file plus additional support documents is at or near
    https://wiki.duraspace.org/display/D...tion+Reference

    Good Luck,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •