Results 1 to 5 of 5

Thread: Problem with repo change: LibreOffice - zypper up dup?!

  1. #1

    Default Problem with repo change: LibreOffice - zypper up dup?!

    I've used the LibreOffice:5.4 repo. Recently there has been a update to that version in the official 42.3:Updates repo.
    So I wanted to switch back to the official stable repo.

    I did this by first uninstalling libreoffice using
    Code:
     zypper rm libreoffice
    . Then I disabled the OBS repo and installed it again using
    Code:
     zypper in libreoffice
    , knowing that now it had to pull LO from the official repo since the other one was disabled.

    These are my repos now:

    Code:
    david@2:~> zypper lr -u
    Repository priorities in effect:                                                                                                                                                       (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository  
          99 (default priority) :  6 repositories
    
    # | Alias                 | Name                              | Enabled | GPG Check | Refresh | URI                                                              
    --+-----------------------+-----------------------------------+---------+-----------+---------+------------------------------------------------------------------
    1 | packman.inode.at-suse | Packman Repository                | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.3/                 
    2 | repo-non-oss          | openSUSE-Leap-42.3-Non-Oss        | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/
    3 | repo-oss              | openSUSE-Leap-42.3-Oss            | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.3/repo/oss/    
    4 | repo-update           | openSUSE-Leap-42.3-Update         | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.3/oss/               
    5 | repo-update-non-oss   | openSUSE-Leap-42.3-Update-Non-Oss | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.3/non-oss/           
    6 | skype-stable          | skype (stable)                    | Yes     | (r ) Yes  | Yes     | https://repo.skype.com/rpm/stable/                               
    7 | skypeforlinux         | skypeforlinux                     | Yes     | (r ) Yes  | Yes     | https://repo.skype.com/rpm/stable
    However there is a problem with the KDE integration using
    Code:
     zypper in libreoffice
    . It looks horrible now, like Window 95.

    I noticed that no themes were being pulled by using zypper in:

    Code:
    david@2:~> sudo zypper -v in libreoffice
    Verbosity: 1
    Non-option program arguments: 'libreoffice' 
    Initializing Target
    Checking whether to refresh metadata for Packman Repository
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Non-Oss
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Oss
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Update
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Update-Non-Oss
    Checking whether to refresh metadata for skype (stable)
    Checking whether to refresh metadata for skypeforlinux
    Loading repository data...
    Reading installed packages...
    Force resolution: No
    Selecting 'libreoffice-5.4.4.2-12.6.x86_64' from repository 'openSUSE-Leap-42.3-Update' for installation.
    Resolving package dependencies...
    Force resolution: No
    
    The following 5 applications are going to be installed:
      LibreOffice Base     
      LibreOffice Calc     
      LibreOffice Draw     
      LibreOffice Impress  
      LibreOffice Writer   
    
    The following 12 NEW packages are going to be installed:
      libreoffice                     5.4.4.2-12.6
      libreoffice-base                5.4.4.2-12.6
      libreoffice-base-drivers-mysql  5.4.4.2-12.6
      libreoffice-calc                5.4.4.2-12.6
      libreoffice-draw                5.4.4.2-12.6
      libreoffice-filters-optional    5.4.4.2-12.6
      libreoffice-impress             5.4.4.2-12.6
      libreoffice-l10n-en             5.4.4.2-12.6
      libreoffice-mailmerge           5.4.4.2-12.6
      libreoffice-math                5.4.4.2-12.6
      libreoffice-pyuno               5.4.4.2-12.6
      libreoffice-writer              5.4.4.2-12.6
    
    12 new packages to install.
    Then interestingly
    Code:
    zypper dup
    gives me:

    Code:
    david@2:~> sudo zypper -v dup
    Verbosity: 1
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Initializing Target
    Checking whether to refresh metadata for Packman Repository
    Retrieving: repomd.xml ..........................................................................................................................................................................................[done]
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Non-Oss
    Retrieving: content .................................................................................................................................................................................[done (1.2 KiB/s)]
    Retrieving: media ...............................................................................................................................................................................................[done]
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Oss
    Retrieving: content .............................................................................................................................................................................................[done]
    Retrieving: media ...............................................................................................................................................................................................[done]
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Update
    Retrieving: repomd.xml ..........................................................................................................................................................................................[done]
    Checking whether to refresh metadata for openSUSE-Leap-42.3-Update-Non-Oss
    Retrieving: repomd.xml ..........................................................................................................................................................................................[done]
    Checking whether to refresh metadata for skype (stable)
    Retrieving: repomd.xml ..........................................................................................................................................................................................[done]
    Checking whether to refresh metadata for skypeforlinux
    Retrieving: repomd.xml ..........................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    Force resolution: No
    Computing upgrade...
    
    The following 3 items are locked and will not be changed by any action:
     Available:
      amarok pattern:games texlive
    
    The following 5 applications are going to be installed:
      LibreOffice Base     
      LibreOffice Calc     
      LibreOffice Draw     
      LibreOffice Impress  
      LibreOffice Writer   
    
    The following 15 NEW packages are going to be installed:
      libreoffice                     5.4.4.2-12.6
      libreoffice-base                5.4.4.2-12.6
      libreoffice-base-drivers-mysql  5.4.4.2-12.6
      libreoffice-calc                5.4.4.2-12.6
      libreoffice-calc-extensions     5.4.4.2-12.6
      libreoffice-draw                5.4.4.2-12.6
      libreoffice-filters-optional    5.4.4.2-12.6
      libreoffice-impress             5.4.4.2-12.6
      libreoffice-kde4                5.4.4.2-12.6
      libreoffice-l10n-en             5.4.4.2-12.6
      libreoffice-mailmerge           5.4.4.2-12.6
      libreoffice-math                5.4.4.2-12.6
      libreoffice-pyuno               5.4.4.2-12.6
      libreoffice-writer              5.4.4.2-12.6
      libreoffice-writer-extensions   5.4.4.2-12.6
    
    15 new packages to install.
    So why is zypper in libreoffice not automatically pulling the KDE dependencies? Seems odd, that I have to do a zypper dup doesn't it?

    Thanks in advance.

    David

  2. #2

    Default Re: Problem with repo change: LibreOffice - zypper up dup?!

    Maybe you disabled automatic installation of recommended packages?

  3. #3

    Default Re: Problem with repo change: LibreOffice - zypper up dup?!

    Might be blind atm, I used Yast and when trying to install LO again this time I clicked on install recommended packages. Now everything works.
    Where can I disable recommended packages again? (Or in this case, enable it once again?)

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Problem with repo change: LibreOffice - zypper up dup?!

    Quote Originally Posted by SF6 View Post
    Might be blind atm, I used Yast and when trying to install LO again this time I clicked on install recommended packages. Now everything works.
    Where can I disable recommended packages again? (Or in this case, enable it once again?)
    There's a checkbox for it in YaST's softwaremanager
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Problem with repo change: LibreOffice - zypper up dup?!

    Quote Originally Posted by SF6 View Post
    Might be blind atm, I used Yast and when trying to install LO again this time I clicked on install recommended packages. Now everything works.
    Where can I disable recommended packages again? (Or in this case, enable it once again?)
    In /etc/zypp/zypp.conf, see the solver.onlyRequires option.

    Or the installRecommends option in /etc/zypp/zypper.conf (which only affects zypper, and not other applications like YaST).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •