Results 1 to 7 of 7

Thread: White screen instead of login

  1. #1
    Join Date
    Nov 2017
    Location
    Somewhere around the middle of Europe.
    Posts
    113

    Default White screen instead of login

    Hello,
    I updated to Tumbleweed 20180206 and weird things happened. After the update, everything was working normally, I was doing stuff I normally do. After some time, I had to leave the computer, so I locked the screen and walked away. When I came back, the screen woke, but it was black with just the cursor. Naturally, I pushed Ctrl-Alt-F1, logged in and rebooted. After reboot, instead of sddm, there is just a white screen with a cursor. I managed to start i3 (which I use for emergency purposes) from tty1 and write this post. I have no idea what to do. It is possible, that I messed something up, but I don't know. If you need any details, I will be happy to provide them.
    Thanks very much for help, I am in a pretty bad situation right now.
    Greenscreener

  2. #2
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    124

    Default Re: White screen instead of login


  3. #3

    Default Re: White screen instead of login

    Delete the folders ~/.cache/ and /var/lib/sddm/.cache/.

    It was a bug in Mesa that caused broken cache files to be written, which can cause application (and desktop) crashes.
    Has been fixed meanwhile (in snapshot 20170206, and also already by an emergency update yesterday), but it may still be necessary to delete the caches once because they already may contain corrupt files.

  4. #4
    Join Date
    Nov 2017
    Location
    Somewhere around the middle of Europe.
    Posts
    113

    Default Re: White screen instead of login

    Thank you very much, it worked. You guys are awesome.

  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,125

    Default Re: White screen instead of login

    Worked for me, too.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  6. #6
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    113

    Default Re: White screen instead of login

    I've updated to 20180208 today (previous was a few weeks ago) and bumped into the same issue. Not sure whether the emergency update was supposed to fix this ?

    I manually cleared the cache in both recommended locations and now my desktop works again, thanks a lot!

  7. #7

    Default Re: White screen instead of login

    Quote Originally Posted by PVince81 View Post
    I've updated to 20180208 today (previous was a few weeks ago) and bumped into the same issue. Not sure whether the emergency update was supposed to fix this ?
    The Mesa update was supposed to fix writing invalid caches, but would not really help if they are already corrupt (written by the buggy version).

    As it turned out, there is a bug in Qt5 as well though which didn't properly handle invalidated caches, which apparently causes the same problem to reappear after every Mesa update.
    A fix is being worked on though:
    http://bugzilla.opensuse.org/show_bug.cgi?id=1080578

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •