Hello,

I'm currently experiencing some issues with SDDM and KWin breaking after making a change to my compositor settings in the KDE Settings Panel (ksystemsettings5). Recently, I tried changing the "Scale method" menu option to see how it would look. Changing this option used to work without issue before (on an old Radeon HD 5670), but this time around, after clicking "Apply", KWin immediately stopped drawing all window decorations, panels, or the desktop background/icons, and all open windows started to behave erratically, leaving rendering artifacts all over. After rebooting in an attempt to clear it up, SDDM now shows a solid white screen, and when I do login and start KDE, the same behavior from before persists. This leaves the KDE desktop in an unusable state, since I now just have a mouse cursor moving around in a solid black void.

I'm still able to use a different display manger such as LightDM and a different WM such as IceWM; this issue seems to exclusively affect SDDM and KDE. When I do manage to login with a different DM/WM, I'm able to access the KDE Settings Panel, but the panels for changing the desktop theme or DM theme only show a solid black box in the settings window (most--not all--other panels still work for some reason). I don't believe it's due to faulty GPU drivers, since I tried running some Unigine GPU benchmarks in an IceWM session and they still render properly.

System info that may be relevant:

  • openSUSE Tumbleweed AMD64
  • GPU: Radeon RX 560
  • Kernel 4.15.0-1-default
  • "amdgpu.dc=1" kernel option enabled in GRUB boot loader settings
  • KDE Plasma 5.11.95, KDE Frameworks 5.42.0, Qt 5.10.0
  • sddm 0.17.0-1.1, kcm-sddm 5.11.95-1.1
  • Mesa 18.0.0-785.1


Fixes I've tried so far that failed:
  • Rebooting (cold and warm reboots), logging out/in, restarting X via Ctrl+Alt+Backspace (multiple times, no effect)
  • Starting KDE via LightDM (doesn't help, KDE still behaves the same)
  • sudo systemctl kill sddm.service (this just causes the screen to flicker wildly across all virtual terminals until I reboot)
  • Killing/restarting plasmashell via command line (it comes back still broken)
  • Changing SDDM theme via /etc/sddm.conf (no effect; all themes show a solid white screen)
  • sddm-greeter --test-mode (also shows a solid white screen, regardless of theme)
  • Changing KDE desktop theme via ~/.kde4/share/config/plasmarc (no effect; desktop still broken, it even seems to ignore the theme setting in plasmarc)
  • Changing SDDM or KDE themes via KDE Settings Panel (I can't even try this now because these two settings panels don't render anymore)
  • Enabling/disabling compositor on startup (tried it both ways, no effect; I had this enabled at the time)
  • Changing the compositor rendering backend (tried both OpenGL options and XRender, no effect; I was using OpenGL 3.1 at the time)
  • Reverting to the option I had before for "Scale method" that caused all this (no effect)
  • zypper dup to bring everything up-to-date (didn't help)