Results 1 to 3 of 3

Thread: shared for all users (wifi) conection keep getting asked for root pwd...

  1. #1

    Default shared for all users (wifi) conection keep getting asked for root pwd...

    Hi all, as per title - i've set up wifi connection and it shared with "all users' from "network settings -> general configuration". Every time i login i greeted with window asking me for root password for seemingly to be able to modify network setting for all users (see screenshot). Every time! I have tried all possible combinations of kwallet - on, of, simple password, passwordless, gpg key... doesn't really matters...every time i login i get popup... and completely baseless request too - no matter if i enter password or not i do get connection activated.
    Any ideas how to get reed of this notification?

  2. #2

    Default Re: shared for all users (wifi) conection keep getting asked for root pwd...

    That's a bug/design flaw in NetworkManager.

    It requires privileges for *modifying* the connection if the passphrase is stored in the user profile (kwallet, gnome-keyring) and that cannot be opened immediately because the user needs to enter a password e.g.
    And modifying a system connection (i.e. shared for all users) is only allowed with the root password in openSUSE.

    Workaround: store the WiFI key system-wide as well (this can be done on the "WiFI security" tab in the connection settings).

    Or, in the case of kwallet, set an empty password for your wallet. (Using pam_kwallet to automatically unlock the wallet on login would probably help as well)

    It would also be possible to change the polkit settings to allow modifying a system connection, but every user could change the connection settings then too.
    Last edited by wolfi323; 06-Feb-2018 at 08:25.

  3. #3

    Default Re: shared for all users (wifi) conection keep getting asked for root pwd...

    Quote Originally Posted by wolfi323 View Post
    That's a bug/design flaw in NetworkManager.
    Workaround: store the WiFI key system-wide as well (this can be done on the "WiFI security" tab in the connection settings).
    thank you, thank you, thank you.... man it was irritating me.....

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •