Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD....

  1. #21

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD....

    Quote Originally Posted by martinprowe View Post
    Thank you. Here it is: http://paste.opensuse.org/43740
    Ok, so you are using radeon.

    As I indicated, try to uninstall the package xf86-video-ati, or create a file /etc/X11/xorg.conf.d/50-mydevice.conf (the exact name doesn't really matter) with this content:
    Code:
    Section "Device"
      Identifier "Default Device"
      Driver "modesetting"
    EndSection
    Maybe using modesetting instead of radeon would avoid the problem, but I don't know (it would still use the same OpenGL driver).
    If it doesn't help, better revert your change, i.e. re-install xf86-video-ati or delete /etc/X11/xorg.conf.d/50-mydevice.conf again.

  2. #22

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD....

    Same problem here. I luckily have a nvidia card I could switch to, and with nouveau it works fine. Performance is worse, however.

  3. #23

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD....

    Quote Originally Posted by mike_ferrara View Post
    I luckily have a nvidia card I could switch to, and with nouveau it works fine. Performance is worse, however.
    You could install the proprietary nvidia driver for increased performance.
    Won't help much if the card itself is weaker/too weak though, of course.

  4. #24

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD.... [SOLVED]

    Closed source nvidia driver is another story all together. Suffice it to say it doesn't work with my Quadro K2000. BUT ... Radeon and FreeCAD now work for me if I set the environment variable: LIBGL_DRI3_DISABLE=true

    Looks like there's a problem with DRI3.

    Like this:

    LIBGL_DRI3_DISABLE=true FreeCAD

    now I'm back in business and I like my AMD card better anyway.

    SOLVED for me. YMMV. I also built my FreeCAD from head of git in an attempt to fix this, and I'm sticking with it.

    -mikef

  5. #25

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD.... [SOLVED]

    Quote Originally Posted by mike_ferrara View Post
    Closed source nvidia driver is another story all together.
    I fully agree with you Mike, I have had no end of problems with nvidia....
    I would like to pick up some advice on upgrading my HD 5500 though. But that a conversation for another place?

    BUT ... Radeon and FreeCAD now work for me if I set the environment variable: LIBGL_DRI3_DISABLE=true FreeCAD
    Wow.... This got me excited! But..... It has not worked for me?

    Can you tell me a bit more about why it may have worked for you? Do we have similar enough systems that it should work for me?
    To be sure that I understand what you are advising, this is what I have done:
    1. Tumbleweed 20180403, KDE 5.12.4, Qt 5.10
    2. Added the string "LIBGL_DRI3_DISABLE=true FreeCAD" (no quotes) to /etc/environment & rebooted.
    3. Check that the variable is available to root & users terminals with ~>printenv LIBGL_DRI3_DISABLE
    4. Tested FreeCAD

    Code:
    mprowe@gzunder:~>                                                                                                                           
    mprowe@gzunder:~>                                                                                                                           
    mprowe@gzunder:~> printenv LIBGL_DRI3_DISABLE                                                                                               
    true FreeCAD                                                                                                                                
    mprowe@gzunder:~> FreeCAD -l                                                                                               
    FreeCAD 0.16, Libs: 0.16RUnknown                                                                                                            
    © Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015                                                                                   
      #####                 ####  ###   ####                                                                                                    
      #                    #      # #   #   #                                                                                                   
      #     ##  #### ####  #     #   #  #   #                                                                                                   
      ####  # # #  # #  #  #     #####  #   #                                                                                                   
      #     #   #### ####  #    #     # #   #                                                                                                   
      #     #   #    #     #    #     # #   #  ##  ##  ##                                                                                       
      #     #   #### ####   ### #     # ####   ##  ##  ##                                                                                       
                                                                                                                                                
    No protocol specified                                                                                                                       
    failed to create drawable                                                                                                                   
    [xcb] Unknown sequence number while processing queue
    [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
    [xcb] Aborting, sorry about that.
    FreeCAD: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
    Aborted
    mprowe@gzunder:~>
    Dho..... Still no go for me!


    Best regards, Martin
    openSUSE Leap 15; KDE Plasma 5.12.5;

  6. #26

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD.... [SOLVED]

    Quote Originally Posted by martinprowe View Post
    2. Added the string "LIBGL_DRI3_DISABLE=true FreeCAD" (no quotes) to /etc/environment & rebooted.
    No that's wrong.
    That sets LIBGL_DRI3_DISABLE to "true FreeCAD", which is nonsense...

    Either add "LIBGL_DRI3_DISABLE=true" to /etc/environment (which will disable DRI3 for *all* applications), or run FreeCAD by typing "LIBGL_DRI3_DISABLE=true FreeCAD" (instead of just FreeCAD) into the shell.

    I suppose you could also disable DRI3 via the xorg.conf...

  7. #27

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD.... [SOLVED]

    Quote Originally Posted by wolfi323 View Post
    No that's wrong.
    Wooo....Hoooooo......

    Thank you Wolfi, for putting me right. Silly me?

    As the thread title says: [SOLVED] .... for me too.

    Regards, Martin

    PS Any suggestions on where to ask Re: upgrading AMD HD5500?
    openSUSE Leap 15; KDE Plasma 5.12.5;

  8. #28

    Default Re: Tumbleweed upgrade from20180202 to 20180203 breaks FreeCAD.... [SOLVED]

    Quote Originally Posted by martinprowe View Post
    Wooo....Hoooooo......

    Thank you Wolfi, for putting me right. Silly me?

    As the thread title says: [SOLVED] .... for me too.

    Regards, Martin

    PS Any suggestions on where to ask Re: upgrading AMD HD5500?
    Sorry about that, I guess I wasn't being clear ... since FreeCAD is the only program that had this problem for me I only set the variable for it when I run it. I do it with a shell alias.

    Funny, I too am looking for an upgrade of my HD5750. I'm not a gamer, but I'd like to support latest OpenCL and OpenGL, maybe with less power dissipation ... though my refurb'd HP Z820 with 32 cores of Xeon isn't miserly with power, now is it?

    Anyway, I'm so happy to have FreeCAD again on the radeon. I was switching in a Quadro K2000 running nouveau every time I needed FreeCAD.

    -mikef

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •