Results 1 to 8 of 8

Thread: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

  1. #1

    Post OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    I have a multple OS installed on my machine with openSUSE Tumbleweed as primary and latest addition to the collection until I decided to try Ubuntu 16.04LTS Mate yesterday. The number of OS includes Windows 7. Everything worked fine until I did a wrong step.
    Before starting the problem, let me add a thing. OpenSUSE KDE is my primary OS for desktop usage. I had auto-mounted all other os and non-os drives through editing /etc/fstab file. One of the drives was containing Linux Mint Cinnamon formatted as an EXT4 partition. The entry on /etc/fstab was done using UUID of each partition rather than it's /dev/sdXY identity. I prepared an Ubuntu USB and installed the os but during the partition of installation, I selected XFS instead of EXT4 for Ubuntu on present Linux Mint Cinnamon to try the performance of XFS under Ubuntu instead of EXT4.
    At this point, I had installed GRUB through OpenSUSE Tumbleweed installation. It had listed every OS in my system in right order. During Ubuntu installation, GRUB installation failed for some reason. Therefore the previous GRUB written by OpenSUSE was left intact. I rebooted the machine and tried to boot the OpenSUSE where all sorts of error messages began to appear during booting. Please see the screenshots to see them at here: https://imgur.com/a/TJ5IP
    Using the live USB, I recovered the GRUB but it has left me all sort of errors. I understand I need to modify /etc/fstab accordingly as per new partition type but nothing worked. I cannot modify the /etc/fstab file withing booting into the OS itself. Hence, I tried to chroot into os using live DVD and install grub from there but the OS does not let me chroot it. It gives an error for missing 'libtinfo.so.5' missing library trying to chroot into the mounted directory. As per images, the boot process is forever stuck at 'a start job is running...'.

    For information, I am using OpenSUSE KDE Tumbleweed [XFS partition]
    Another OS is Windows 7, Linux Mint 18.3, Ubuntu 16.04 LTS.
    Non-OS drives are an NTFS partition for keeping data.

    The machine is Lenovo B570e.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Use a live distro or booting OS to edit the /etc/fstab to the correct file system or just add nofail or just remove the entry. It is trying to mount the partition using the wrong file system. I doubt it is a grub problem simply a failed mount.

  3. #3

    Question Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Quote Originally Posted by gogalthorp View Post
    Use a live distro or booting OS to edit the /etc/fstab to the correct file system or just add nofail or just remove the entry. It is trying to mount the partition using the wrong file system. I doubt it is a grub problem simply a failed mount.
    This is the question. I am unable to 'chroot' into OpenSUSE. I mount necessary partitions but at the step of 'chroot /mnt' it says 'libtinfo.so.5' is missing library. Is there other way to edit /etc/fstab file?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Don't have to chroot to edit a file just mount the partition

  5. #5

    Default Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Quote Originally Posted by gogalthorp View Post
    Don't have to chroot to edit a file just mount the partition
    It does not let me. Simple mounting does not provide any file named 'fstab' in /etc/ directory. It only gives a file with following name 'fstab.live-installer' where those partitions are mentioned which I given the partioner at the installation ie. a root partition and swap one. There is no /etc/fstab entry over there.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Has to be sure you mount the right partition?

  7. #7

    Post Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Yes, I'm. Is it because I have installed GRUB from another os the /etc/fstab file is missing from OpenSUSE? Is it while during reinstallation of GRUB from Ubuntu, the /etc/fstab has been modified to it's default state? I am not expert but missing critical files is important symptom to look at. Does I mean useful information, pardon if not.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: OpenSUSE KDE failed to boot after installing another Linux distribution alongside.

    Quote Originally Posted by mahmadmujtaba View Post
    Yes, I'm. Is it because I have installed GRUB from another os the /etc/fstab file is missing from OpenSUSE? Is it while during reinstallation of GRUB from Ubuntu, the /etc/fstab has been modified to it's default state? I am not expert but missing critical files is important symptom to look at. Does I mean useful information, pardon if not.
    No. a Grub install should not touch fstab. If it is missing then you did something else you have not reported. In any case you can never boot the OS without a fstab since it tells the kernel what to mount..

    What grub did you use I had assumed you used a live rescue DVD but maybe not
    You should only use openSUSE stuff of the same version to repair openSUSE internals.hard to say what another OS will have installed.

    You tried this by chroot using what OS?

    BTW fstab for the installed os won't be in /etc/fstab when running from a live. It will be in themountpoint/etc/fstab

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •