Results 1 to 5 of 5

Thread: update error

  1. #1

    Default update error

    I just installed OpenSuse 42.3 whit KDE and trying to run the automatic updates I'm getting this message below and the update does not happen

    - KNotify Mon Feb 5 07:55:21 2018: Package failed to install One of the selected packages failed to install correctly.
    More information is available in the detailed report.
    What should I do ?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: update error

    what's your repo list?
    Code:
    zypper lr -d
    try updating manually
    Code:
    sudo zypper up

  3. #3

    Default Re: update error

    The result from zypper ld -d

    Code:
    > zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                            | Service
    ---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------+--------
     1 | openSUSE-Leap-42.3-0      | openSUSE-Leap-42.3-0                    | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001BFC3653D9BF6129527333-0:0-part2 |        
     2 | repo-debug                | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/                            |        
     3 | repo-debug-non-oss        | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/                        |        
     4 | repo-debug-update         | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                                       |        
     5 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/                                   |        
     6 | repo-non-oss              | openSUSE-Leap-42.3-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/                              |        
     7 | repo-oss                  | openSUSE-Leap-42.3-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                                  |        
     8 | repo-source               | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/                           |        
     9 | repo-source-non-oss       | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/                       |        
    10 | repo-update               | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                                             |        
    11 | repo-update-non-oss       | openSUSE-Leap-42.3-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                                         |        
    sergio@linux-ka2t:~>

  4. #4

    Default Re: update error

    Quote Originally Posted by I_A View Post
    ]
    try updating manually
    Code:
    sudo zypper up
    Code:
    I try it and get those erros:
    
    
    Checking for file conflicts: .........................................................................................................[done]
    (  1/243) Installing: libeot0-0.01-4.1.x86_64 ........................................................................................[done]
    (  2/243) Installing: glibc-locale-2.22-10.1.x86_64 .................................................................................[error]
    Installation of glibc-locale-2.22-10.1.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed:    installing package glibc-locale-2.22-10.1.x86_64 needs 251MB on the / filesystem
    The above error I left with "i"

    Code:
    ]
    (117/243) Installing: kernel-default-4.4.104-39.1.x86_64 ....................................................................................................[error]
    Installation of kernel-default-4.4.104-39.1.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed:    installing package kernel-default-4.4.104-39.1.x86_64 needs 12MB on the / filesystem
    
    Abort, retry, ignore? [a/r/i] (a):
    The above error I try "r" but not work and then I do the "i" option
    Do these errors seem serious?

  5. #5

    Default Re: update error

    Quote Originally Posted by josemanoel View Post
    Do these errors seem serious?
    Sure.
    Your hard disk is full, so the updates cannot be installed.

    Free up some space, maybe delete some snapshots in YaST->Misc->Snapper (or with the snapper command line tool) and/or clean up /tmp/ and /var/tmp/.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •