Results 1 to 7 of 7

Thread: Apache2 configuration question

  1. #1

    Default Apache2 configuration question

    I'm getting the following error from Apache:

    Code:
    [core:alert] [pid 3352] [client ::1:45900] /[path]/.htaccess: Options not allowed here
    I've tried adding/modifying the following sections of the default-server.conf and vhosts.d/localhost.conf files with various combinations of the below options, but to no avail.

    Code:
    Options Indexes FollowSymLinks
    AllowOverride All Options
    It seems this error persists regardless of what follows Options or AllowOverride.

    Any idea of what else might be causing this error?
    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Apache2 configuration question

    Just give the webroot folder these options
    Code:
     <Directory /path/to/vhost/webroot/>
      AllowOverride All
      Require all granted
     </Directory>
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Apache2 configuration question

    Quote Originally Posted by Knurpht View Post
    Just give the webroot folder these options
    Code:
     <Directory /path/to/vhost/webroot/>
      AllowOverride All
      Require all granted
     </Directory>
    It already has those options. I'm still getting the error.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Apache2 configuration question

    Quote Originally Posted by z2 View Post
    It already has those options. I'm still getting the error.
    No, you have a line

    Code:
      AllowOverride All Options
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Apache2 configuration question

    Ok, well, I deleted that. I'm still getting the same error.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Apache2 configuration question

    And, please post output/content of files between CODE tags, the # in de layout ribbon.

    If you don't succeed, post the content of the entire file like that.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Apache2 configuration question

    I got it fixed. I had modified the webroot folder and neglected to change the settings in mod_userdir.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •