Results 1 to 2 of 2

Thread: Can't open files in certain dir with Japanese characters

  1. #1

    Default Can't open files in certain dir with Japanese characters

    Hi,

    when I try opening some files in
    Code:
    Documents/Japan 「日本」
    using Dolphin I get a LO error message:
    HTML Code:
    /home/david/Documents//Japan 「日本」/Folder/170516_Memo.odt does not exist.
    Checking the directory in the terminal reveals that the files exist, however file names containing Japanese characters are not displayed correctly (the directory path however shows Kanji correctly!):

    Code:
    david@pc:~/Documents/Japan 「日本」> ls
    ????????????????????????.odp
    participants.odt   
    ???????????????????????? recommendation ??????.odt
    Kaizen ?????????????????? ??????.odt
    
    
    Even the files, that do not contain Japanese characters won't open in LO.
    On the other hand, photos that are placed in the pictures directory with Japanese characters open just fine.

    What to do?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,567

    Default Re: Can't open files in certain dir with Japanese characters

    Quote Originally Posted by SF6 View Post
    Hi,

    when I try opening some files in
    Code:
    Documents/Japan 「日本」
    using Dolphin I get a LO error message:
    HTML Code:
    /home/david/Documents//Japan 「日本」/Folder/170516_Memo.odt does not exist.
    Checking the directory in the terminal reveals that the files exist, however file names containing Japanese characters are not displayed correctly (the directory path however shows Kanji correctly!):

    Code:
    david@pc:~/Documents/Japan 「日本」> ls
    ????????????????????????.odp
    participants.odt   
    ???????????????????????? recommendation ??????.odt
    Kaizen ?????????????????? ??????.odt
    
    
    Even the files, that do not contain Japanese characters won't open in LO.
    On the other hand, photos that are placed in the pictures directory with Japanese characters open just fine.

    What to do?

    Thanks.
    no issues here opening files containing Japanese characters (or in directories with Japanese characters) on my English / Japanese 42.3 system.
    Have language in Yast set to en_NZ & use UTF-8 encoding.

    Have you set in Libreoffice > tools > options > language settings > languages > Asian - Japanese

    I don't think libreoffice is your issue though as I get
    Code:
    farcus@linux-aw6a:~/Documents/Japan 「日本」> ls
    テスト.odt
    
    What does locale show?

    Code:
    farcus@linux-aw6a:~> locale
    Code:
    LANG=en_NZ.UTF-8
    LC_CTYPE="en_NZ.UTF-8"
    LC_NUMERIC="en_NZ.UTF-8"
    LC_TIME="en_NZ.UTF-8"
    LC_COLLATE="en_NZ.UTF-8"
    LC_MONETARY="en_NZ.UTF-8"
    LC_MESSAGES="en_NZ.UTF-8"
    LC_PAPER="en_NZ.UTF-8"
    LC_NAME="en_NZ.UTF-8"
    LC_ADDRESS="en_NZ.UTF-8"
    LC_TELEPHONE="en_NZ.UTF-8"
    LC_MEASUREMENT="en_NZ.UTF-8"
    LC_IDENTIFICATION="en_NZ.UTF-8"
    LC_ALL=


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •