Results 1 to 8 of 8

Thread: Firewalld service does not start on boot

  1. #1

    Default Firewalld service does not start on boot

    The firewalld service is configured for the necessary ports I use, enabled, started but on each reboot I find that the service is not started. Is this behavior considered normal?
    And I am exposed to the outside world threats. By-the-way, why SuSEFirewall2 was replaced with this firewalld s*** ?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Firewalld service does not start on boot

    Quote Originally Posted by ZeroG View Post
    The firewalld service is configured for the necessary ports I use, enabled, started but on each reboot I find that the service is not started. Is this behavior considered normal?
    What does the following show?
    Code:
    sudo systemctl status firewalld
    And I am exposed to the outside world threats. By-the-way, why SuSEFirewall2 was replaced with this firewalld s*** ?
    There are a number of existing threads discussing this topic....
    https://forums.opensuse.org/showthre...ight=firewalld
    https://forums.opensuse.org/showthre...51#post2852651
    https://forums.opensuse.org/showthre...ight=firewalld

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Firewalld service does not start on boot

    BTW, what is your inferred objection with using firewalld?

  4. #4

    Default Re: Firewalld service does not start on boot

    Maybe a firewall should be 100% reliable?

    In YaST -> Services Manager firewalld is enabled and active, I can enter the config tool via YaST, but

    Code:
    sudo systemctl status firewalld
    [sudo] password for root: 
    ● firewalld.service
       Loaded: not-found (Reason: No such file or directory)
       Active: inactive (dead)
    On 4 machines I checked, 2 have this unbelievable status, 2 are up and running. 50% chance for having a firewall...

    That's not how a firewall works.
    Kind regards

    raspu

  5. #5

    Default Re: Firewalld service does not start on boot

    Ok, I found a solution for the problem - and it was SuSEfirewall2 service, after I disabled SuSEfirewall2.service the firewalld service works as expected.
    Therefore it is an inconsistency in SuSEfirewall2 to firewalld replacement procedure.

    What about SuSEfirewall2 - to me it was much more intuitive and trustworthy to use from a common user perspective than firewalld and its moronic interface - both gui & cmd, moreover that in addition cli is removed at ver 0.5

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Firewalld service does not start on boot

    Quote Originally Posted by suse_rasputin View Post
    Maybe a firewall should be 100% reliable?

    In YaST -> Services Manager firewalld is enabled and active, I can enter the config tool via YaST, but

    Code:
    sudo systemctl status firewalld
    [sudo] password for root: 
    ● firewalld.service
       Loaded: not-found (Reason: No such file or directory)
       Active: inactive (dead)
    On 4 machines I checked, 2 have this unbelievable status, 2 are up and running. 50% chance for having a firewall...

    That's not how a firewall works.
    I get the idea that you are hijacking other one's thread. But when you have four systems, do you mind in confirming that all four have the same version of openSUSE? After all we are ins a transition state moving from SuSEfirewall2 to firewalld, so e.g. Leap42.3 and older Tumbleweeds will still not have firewalld at all.
    Henk van Velden

  7. #7

    Default Re: Firewalld service does not start on boot

    OK, my last reply in this thread: Yes, all 4 have been updated the last week and manually switched to firewalld, as described in the other thread linked above.

    Unbelievable.
    Kind regards

    raspu

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Firewalld service does not start on boot

    Quote Originally Posted by ZeroG View Post
    Ok, I found a solution for the problem - and it was SuSEfirewall2 service, after I disabled SuSEfirewall2.service the firewalld service works as expected.
    Therefore it is an inconsistency in SuSEfirewall2 to firewalld replacement procedure.
    Yes, it is necessary to stop and disable SuSEfirewall2 before enabling/starting firewalld. It was a deliberate decision to leave the original firelwall in place (for obvious security/administrative reasons) until the administrator decides to invoke the changes.

    What about SuSEfirewall2 - to me it was much more intuitive and trustworthy to use from a common user perspective than firewalld and its moronic interface - both gui & cmd, moreover that in addition cli is removed at ver 0.5
    You would need to ask the developers that question to get a detailed answer, but resources are limited and that often influences these decisions.
    https://lists.opensuse.org/opensuse-.../msg00464.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •