Results 1 to 7 of 7

Thread: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or so)

  1. #1

    Default Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or so)

    So I booted in maintenance mode, looked at /etc/shadow which had no user except root and root had no password. Okay, so I used "passwd" and set one -- no luck. So I re-set it to "xxx" so as to avoid language-layout specific problems with the keyboard -- no luck. so I "chroot"ed from another installation mounted the new installation, set the password, synced the disk -- no luck. So I re-installed with only root as user -- no luck.

    Umm. Yes. Any ideas? (And don't suggest Leap, I love tumbleweed) .

  2. #2

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    Can you login from the tty? Alt-Ctrl-F1? I found with gnome as the default DM that I could not login to the GUI, but could login from tty1. And I didn't have the same problem when I installed xfce4 and used lightdm as my login greeter

  3. #3

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    No, I can't. *sigh*

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,777

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    Isn' that where maintenance mode is for? Login as root without needing an (in any case unknown) password? Or am I completely at the wrong track here?

    And why do you want to set the root password of maintenance mode? Blocking it?
    Henk van Velden

  5. #5

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    Quote Originally Posted by hcvv View Post
    Isn' that where maintenance mode is for? Login as root without needing an (in any case unknown) password? Or am I completely at the wrong track here?
    Yes .

    I'm blocked at the normal login Screen. Neither a "standard" user (me) nor root can log in into a normal KDE/Plasma session.

    Quote Originally Posted by hcvv View Post
    And why do you want to set the root password of maintenance mode? Blocking it?
    I wanted to set the root password for normal root (is there a difference to maintenance mode root at all?). Then I wanted to log in as "normal" root so that I can call yast to create users (or "sudo"). That is not possible while I can't start KDE/Plasma. And I don't want to use maintenance mode permanently, I want KDE/Plasma sessions.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,777

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    Quote Originally Posted by wodenhof View Post
    Yes .

    I'm blocked at the normal login Screen. Neither a "standard" user (me) nor root can log in into a normal KDE/Plasma session.
    So ,that is your real problem.
    Then why do you not start a thread with that problem in the title and the exact description of what you see in the body?

    Quote Originally Posted by wodenhof View Post
    I wanted to set the root password for normal root (is there a difference to maintenance mode root at all?). Then I wanted to log in as "normal" root so that I can call yast to create users (or "sudo"). That is not possible while I can't start KDE/Plasma. And I don't want to use maintenance mode permanently, I want KDE/Plasma sessions.
    That is a differ ent "root". As you saw, the /etc/passwd and /etc/shadow of maintanance mode only have root, the real ones have at least 20 users.

    But, as said, as the root cause of your problem is unknown, I would not advice you to change things in those files just with the idea "you never know".

    BTW, you should never try to log in in the GUI with user root.

    BTW again, can you still login in the CLI? Then, as root, you can run YaST
    Code:
    yast
    But again, my advice is to describe your problem in a new thread to get advice about how to analyze, debug and eventually repair it.
    Henk van Velden

  7. #7

    Default Re: Fresh install (kernel 4.14.15) but can not log in as user nor as root (wrong identification or s

    Quote Originally Posted by hcvv View Post
    So ,that is your real problem.
    Then why do you not start a thread with that problem in the title and the exact description of what you see in the body?
    I thought I did exactly that?!? I can not log in. Neither in SDDM nor in a console.
    Quote Originally Posted by hcvv View Post
    That is a differ ent "root". As you saw, the /etc/passwd and /etc/shadow of maintanance mode only have root, the real ones have at least 20 users.
    Ahh, I didn't know that. How do I get at the real ones?
    Quote Originally Posted by hcvv View Post
    But, as said, as the root cause of your problem is unknown, I would not advice you to change things in those files just with the idea "you never know".
    Okay.
    Quote Originally Posted by hcvv View Post
    BTW again, can you still login in the CLI? Then, as root, you can run YaST
    No, I cannot log in at all execpt as maintenance root.
    Quote Originally Posted by hcvv View Post
    But again, my advice is to describe your problem in a new thread to get advice about how to analyze, debug and eventually repair it.
    Will try. The problem is, I don't see what I did wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •