Results 1 to 6 of 6

Thread: clocking HD 7870

  1. #1
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    362

    Default clocking HD 7870

    Is there any way to modify the gpu and memory speeds on this card with the open source drivers since they are the only ones I have available to me.

    It would be quite preferable to be able to maintain the new settings across reboots.

    Asus sold the card with a slight overclock and after running it with the proprietary drivers before the card became unsupported which provide for this with the use an open source utility available, I found out I like amd's reference clocks better.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: clocking HD 7870

    Quote Originally Posted by Scott_Swinyard View Post
    Is there any way to modify the gpu and memory speeds on this card with the open source drivers since they are the only ones I have available to me.

    It would be quite preferable to be able to maintain the new settings across reboots.

    Asus sold the card with a slight overclock and after running it with the proprietary drivers before the card became unsupported which provide for this with the use an open source utility available, I found out I like amd's reference clocks better.
    Hi
    That's a Pitcairn Southern Island card?
    Code:
    /sbin/lspci -nnk |grep VGA
    If so you can run the amdgpu driver by enabling it via grub boot settings
    Code:
    si_support=1 cik_support=0
    You can tweak/view the clock settings via;
    Code:
    echo auto > /sys/class/drm/card0/device/power_dpm_force_performance_level
    
    cat /sys/kernel/debug/dri/0/amdgpu_pm_info
    uvd    disabled
    vce    disabled
    power level 0    sclk: 30000 vddc: 3850
    
    echo high > /sys/class/drm/card0/device/power_dpm_force_performance_level
    
    cat /sys/kernel/debug/dri/0/amdgpu_pm_info
    uvd    disabled
    vce    disabled
    power level 4    sclk: 80000 vddc: 4250
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    362

    Default Re: clocking HD 7870

    Thanks for your reply.

    scott@localhost:~> /sbin/lspci -nnk |grep VGA
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition] [1002:6818]



    I'm not already running the amdgpu driver? I have not installed any proprietary drivers in this installation of Tumbleweed. What will it do to the driver I am already running if I execute this command. It works great I don't want to ruin it.

    I'm sorry for my ignorance here but I don't understand how to use the command to view /tweak you gave me either. Guess I need a little hand holding if you are willing.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: clocking HD 7870

    Quote Originally Posted by Scott_Swinyard View Post
    Thanks for your reply.

    scott@localhost:~> /sbin/lspci -nnk |grep VGA
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition] [1002:6818]



    I'm not already running the amdgpu driver? I have not installed any proprietary drivers in this installation of Tumbleweed. What will it do to the driver I am already running if I execute this command. It works great I don't want to ruin it.

    I'm sorry for my ignorance here but I don't understand how to use the command to view /tweak you gave me either. Guess I need a little hand holding if you are willing.
    Hi
    Try;
    Code:
    /sbin/lspci -nnk |grep -A3 VGA
    Should show if radeon (I suspect it is) running rather than amdgpu. No need for the proprietary driver...this won't work for your card anyway...

    You need to be root user to run the commands.... But lets see your driver first. You should have a /etc/X11/xorg.conf.d/10-amdgpu.conf file present as well?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    362

    Default Re: clocking HD 7870

    scott@localhost:~> /sbin/lspci -nnk |grep -A3 VGA
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [R
    adeon HD 7870 GHz Edition] [1002:6818]
    Subsystem: ASUSTeK Computer Inc. Device [1043:042f]
    Kernel driver in use: radeon
    Kernel modules: radeon, amdgpu



    10-amdgpu.conf:

    Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
    EndSection


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: clocking HD 7870

    Quote Originally Posted by Scott_Swinyard View Post
    scott@localhost:~> /sbin/lspci -nnk |grep -A3 VGA
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [R
    adeon HD 7870 GHz Edition] [1002:6818]
    Subsystem: ASUSTeK Computer Inc. Device [1043:042f]
    Kernel driver in use: radeon
    Kernel modules: radeon, amdgpu



    10-amdgpu.conf:

    Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
    EndSection

    Hi
    Check that the xf86-video-amdgpu package is installed as well.....

    So add those boot options in the previous post to the grub kernel boot line (si_support=1 cik_support=0), blacklist the radeon driver and rebuild initrd;

    Code:
    vi /etc/modprobe.d/50-radeon.conf (and add);
    blacklist radeon
    
    (save and rebuild initrd);
    mkinitrd
    Reboot and check the lspci output to see your using the amdgpu driver.

    If doesn't work, remove the blacklist file , rebuild intird and reboot to fallback to the radeon driver.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •