Results 1 to 3 of 3

Thread: OpenSuse 12.1 - libCurl4 update

  1. #1

    Default OpenSuse 12.1 - libCurl4 update

    Hello,

    I have come across an issue wherein for an internal apache / php website hosted on OpenSuse 12.1 I need to update the curl version to at least 7.34.0 to get access to TLS 1.2. Due to legacy code that has yet to be updated, I cannot simply upgrade the php version, I have to upgrade the version of libcurl4 without touching the php version. As far as I can tell, so long as I update libcurl4 to at least 7.34.0 I won't need to touch php5-curl as I believe that is simply for communication with libcurl4. Correct me if I am wrong though.

    My main question is where can I find / how can I compile a version of libcurl4 that is at least 7.34.0 if not the latest version for use with OpenSuse 12.1. (Currently I am running php 5.3.8 and libcurl 7.22.0).

    Any help in this will be greatly appreciated!

    Thank you,
    Daniel

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: OpenSuse 12.1 - libCurl4 update

    As openSUSE 12.1 is out of support since 15th May 2013 I doubt you will find any recent software build for it. Nor do I think that many people will still have a running 12.1 and thus be able to give you much inside information about it.

    Freezing a system to a certain version status because it is running perfectly and no changes are to be made might look as a nice concept for stability until the day comes that, contrary to the plan, a change must be made.

    I hope your Apache server is not accessable from the Internet, because you are now more then 4 years behind with security patches.
    Henk van Velden

  3. #3

    Default Re: OpenSuse 12.1 - libCurl4 update

    http://linuxcampinas.blogspot.cz/201...source-on.html
    Quote Originally Posted by danielcrawford View Post
    Hello,

    I have come across an issue wherein for an internal apache / php website hosted on OpenSuse 12.1 I need to update the curl version to at least 7.34.0 to get access to TLS 1.2. Due to legacy code that has yet to be updated, I cannot simply upgrade the php version, I have to upgrade the version of libcurl4 without touching the php version. As far as I can tell, so long as I update libcurl4 to at least 7.34.0 I won't need to touch php5-curl as I believe that is simply for communication with libcurl4. Correct me if I am wrong though.

    My main question is where can I find / how can I compile a version of libcurl4 that is at least 7.34.0 if not the latest version for use with OpenSuse 12.1. (Currently I am running php 5.3.8 and libcurl 7.22.0).

    Any help in this will be greatly appreciated!

    Thank you,
    Daniel
    I know only about three big deprecations in migration from PHP 5.3 to PHP 5.4/5.5/5.6. Register_globals, short_open_tags and magic_quotas are removed. Short open_tags you can fix by simple regular expression applied to all files. The other ones you can emulate by this: https://justinklemm.com/fix-replicat...obals-php-5-4/

    If you need PHP 5.3, what about latest openSUSE with manually compiled old PHP, perhaps done by this manual: http://linuxcampinas.blogspot.cz/201...source-on.html ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •