Results 1 to 4 of 4

Thread: Can't play DVD

  1. #1
    Join Date
    Oct 2008
    Location
    Stuttgart, Germany
    Posts
    65

    Default Can't play DVD

    Hi,

    I did the one-click install for KDE. I got two conflicts, one of which I couldn't resolve:
    nothing provides libmad.so.0()(64bit) needed by gstreamer-plugins-ugly-orig-addon-1.8.3-10.3.x86_64

    I broke the dependency and continued. At the end of the installation, I was told that 'lame' could not be installed.
    When I put a DVD in the reader and then selected 'Open video player', dragon player started to show the video, but without any sound.
    I then switched all system packages to Packman, as explained in the one-click installation guide.

    I have sound now! But the DVD stops after some introductory scenes. With one of the DVDs I tried, I get a menu (Play, setup, ...). When I click 'play', it starts and everything is ok, but it stops after 12s.

    When I select 'Open with File Manager' and then click on a VOB file, I see either nothing or something completely scrambled.

    I enabled additional repositories in yast and installed libmad. I then repeated the one-click install, without any conflicts or errors, but I still can't play DVDs.

    Any help appriciated.

    Thanks, Stephan

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Can't play DVD

    I confess I do not know what these symptoms mean.

    One requirement to play DVDs is the application libdvdcss2. Do you have that installed ? I do not know what the symptoms will be if that library not installed (which is why my question), but I do know that it must be installed.

    There are many guides/tips on how to install it, such as this one (which I found now after a google search) : https://sites.google.com/site/easyli...t/opensusemate

  3. #3
    Join Date
    Oct 2008
    Location
    Stuttgart, Germany
    Posts
    65

    Default Re: Can't play DVD

    Yes, libdvdcss2 is installed, version 1.4.0-1.1

  4. #4

    Default Re: Can't play DVD

    Quote Originally Posted by stephanhh View Post
    I did the one-click install for KDE. I got two conflicts, one of which I couldn't resolve:
    nothing provides libmad.so.0()(64bit) needed by gstreamer-plugins-ugly-orig-addon-1.8.3-10.3.x86_64
    Please post your repo list:
    Code:
    zypper lr -d
    libmad0 has been released as maintenance update for 42.3, so it is available in the standard Update repo.
    There should be absolutely no need for additional repos (except Packman, but they do not provide libmad and lame anymore because it is part of the standard distribution now), and adding random ones may actually break things.

    Also, it would be helpful to know what video player(s) you tried that gave you problems.
    Last edited by wolfi323; 29-Jan-2018 at 12:38.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •