Results 1 to 9 of 9

Thread: Raspi 3 XFCE image fails on first boot

  1. #1

    Default Raspi 3 XFCE image fails on first boot

    Hi!

    Downloaded the Raspi 3 XFCE image dated 04.12.2017 and checked the sha256 sum. Burned it to a 16 GB SD-card (Sandisk ultra, in the meantime I tried 3 different cards, all working fine with images of Raspbian).

    On first boot I get "Loading ...vmx", then "Loading initram.vmx" and the a kernel panic:

    Initramfs unpacking failed: write error
    Kernel panic - not syncing: VFS: Unable Unable to mount root fs on unusal block 0/0
    ...


    I also tried to prepare the card with Win32Diskimager, same result. I tried this here

    https://lists.opensuse.org/opensuse-.../msg00025.html

    Makes no difference.

    Anyone who got this image to work?
    Kind regards

    raspu

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,324
    Blog Entries
    15

    Default Re: Raspi 3 XFCE image fails on first boot

    Quote Originally Posted by suse_rasputin View Post
    Hi!

    Downloaded the Raspi 3 XFCE image dated 04.12.2017 and checked the sha256 sum. Burned it to a 16 GB SD-card (Sandisk ultra, in the meantime I tried 3 different cards, all working fine with images of Raspbian).

    On first boot I get "Loading ...vmx", then "Loading initram.vmx" and the a kernel panic:

    Initramfs unpacking failed: write error
    Kernel panic - not syncing: VFS: Unable Unable to mount root fs on unusal block 0/0
    ...


    I also tried to prepare the card with Win32Diskimager, same result. I tried this here

    https://lists.opensuse.org/opensuse-.../msg00025.html

    Makes no difference.

    Anyone who got this image to work?
    Hi
    For the JeOS image it's fixed, two things had to change, serial is now on ttyS1 and reduce the cma entry to 300M from 384.

    Do you have a access to serial connection? Try the above with memory, also look at increasing the debug log level to 9. Just press e to edit grub and add on the linux line.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,324
    Blog Entries
    15

    Default Re: Raspi 3 XFCE image fails on first boot

    Hi
    OK, confirmed, all the images got changed (see at the end of line 21);
    https://build.opensuse.org/package/v....kiwi?expand=1

    It takes awhile for the changes to propagate out for download...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Raspi 3 XFCE image fails on first boot

    ...some days? Will wait then... Will the image date change, so that I can see somethink has changed? ;-)

    Many thanks for the reply!
    Kind regards

    raspu

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,324
    Blog Entries
    15

    Default Re: Raspi 3 XFCE image fails on first boot

    Quote Originally Posted by suse_rasputin View Post
    ...some days? Will wait then... Will the image date change, so that I can see somethink has changed? ;-)

    Many thanks for the reply!
    Hi
    Yes the image date will change, many days more likely, things move slow through the build process and openQA... The memory change is only needed to boot the first time, the serial change can be made permanent via yast bootloader....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Raspi 3 XFCE image fails on first boot

    IMO

    Stay away from Win32DiskManager, it can't do anything useful
    Always wipe the install media (sdcard) before burning a new image to it
    Always use the exact procedure described in the Download page for your image to burn the image, don't use Rasbian or Windows or any other tools.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: Raspi 3 XFCE image fails on first boot

    "Always wipe the install media (sdcard) before burning a new image to it"

    ...I usually format the cards in my photo cam, is that enough?
    Kind regards

    raspu

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,324
    Blog Entries
    15

    Default Re: Raspi 3 XFCE image fails on first boot

    On Fri 26 Jan 2018 05:06:02 PM CST, suse rasputin wrote:

    "Always wipe the install media (sdcard) before burning a new image to
    it"

    ....I usually format the cards in my photo cam, is that enough?


    Hi
    I use the wipefs -a command from linux to clean out the partitions and
    device...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.104-39-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Raspi 3 XFCE image fails on first boot

    Since an sdcard is solid state,
    It's probably good enough to fdisk or gdisk, removing partitions.

    Didn't really mean to go the extra step to zero out the data or similar, although it might also be a good idea to clear the memory traps with TRIM (although I haven't actually done this, but then I usually use 16GB and 32GB sdcards which means I always have plenty of available storage).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •