Results 1 to 8 of 8

Thread: help resolve zypper dup

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,447

    Default help resolve zypper dup

    I got notice of 200+ updates available for TW. When I ran zypper dup, I got this error message:
    Code:
    Retrieving repository 'Main Repository (NON-OSS)' metadata .......................[done]
    Building repository 'Main Repository (NON-OSS)' cache ............................[done]
    Retrieving repository 'Main Repository (OSS)' metadata ...........................[done]
    Building repository 'Main Repository (OSS)' cache ................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    3 Problems:
    Problem: yast2-bootloader-4.0.13-1.2.x86_64 requires rubygem(ruby:2.5.0:cfa_grub2) >= 0.
    5.1, but this requirement cannot be provided
    Problem: ruby2.4-rubygem-ruby-augeas-0.5.0-3.6.x86_64 requires ruby(abi) = 2.4.0, but th
    is requirement cannot be provided
    Problem: yast2-storage-ng-4.0.70-1.1.noarch requires yast2 >= 4.0.24, but this requireme
    nt cannot be provided
    
    Problem: yast2-bootloader-4.0.13-1.2.x86_64 requires rubygem(ruby:2.5.0:cfa_grub2) >= 0.
    5.1, but this requirement cannot be provided
      uninstallable providers: ruby2.5-rubygem-cfa_grub2-0.6.5-1.3.i586[download.opensuse.or
    g-oss]
                       ruby2.5-rubygem-cfa_grub2-0.6.5-1.3.x86_64[download.opensuse.org-oss]
     Solution 1: Following actions will be done:
      deinstallation of ruby2.4-2.4.3-2.1.x86_64
      deinstallation of ruby2.4-rubygem-ruby-dbus-0.14.0-1.1.x86_64
     Solution 2: deinstallation of libstorage-ng-ruby-3.3.112-1.1.x86_64
     Solution 3: deinstallation of yast2-bootloader-4.0.13-1.1.x86_64
     Solution 4: keep obsolete yast2-bootloader-4.0.13-1.1.x86_64
     Solution 5: break yast2-bootloader-4.0.13-1.2.x86_64 by ignoring some of its dependenci
    es
    
    The only other "repo" I have is the Tumbleweed install disk. Should I add another repo? If so, which one? I tried adding both packman and Google last week and both failed, even though I did it from links in the forum.

    I was thinking I could just wait until the rubygem shows up or keep the obsolete yast2-bootloader.

    Recommendations?
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  2. #2

    Default Re: help resolve zypper dup

    TW switched to Ruby 2.5 on snapshot 20180124. During upgrade, Ruby 2.4 will be removed and Ruby 2.5 will be installed instead.

    When I performed the upgrade, this switch was done automatically. So I am wondering is there anything installed in your system prevents this switch happening automatically.

    Have you tried to choose option 1 to see if any further error messages will pop up? Anyway, you can cancel the upgrade even after you choose option 1 and get any new message.

    BTW, I think it will help others to diagnose if you give the results of
    Code:
    sudo zypper lr -E --uri
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,447

    Default Re: help resolve zypper dup

    When I read my own post about repos, I realized that I had the dvd enabled but not in the drive. I disabled the dvd "repo" and ran the zypper dup. The error disappeared. I guess the dvd had priority over the online repos. As mentioned above, TW upgraded to Ruby 2.5. Thanks for trying to help me out
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  4. #4
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,447

    Default Re: help resolve zypper dup

    Quote Originally Posted by cnzhx View Post
    TW switched to Ruby 2.5 on snapshot 20180124. During upgrade, Ruby 2.4 will be removed and Ruby 2.5 will be installed instead.

    When I performed the upgrade, this switch was done automatically. So I am wondering is there anything installed in your system prevents this switch happening automatically.

    Have you tried to choose option 1 to see if any further error messages will pop up? Anyway, you can cancel the upgrade even after you choose option 1 and get any new message.

    BTW, I think it will help others to diagnose if you give the results of
    Code:
    sudo zypper lr -E --uri
    I added the last 3 repos after I resolved the error message by disabling the dvd.
    Code:
    # | Alias                                  | Name                      | Enabled | GPG Check | Refresh | URI                                                   
    --+----------------------------------------+---------------------------+---------+-----------+---------+------------------------------------------------------
    1 | download.opensuse.org-non-oss          | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss/
    2 | download.opensuse.org-oss              | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/     
    3 | download.opensuse.org-tumbleweed       | Main Update Repository    | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/       
    4 | google-chrome                          | google-chrome             | Yes     | (r ) Yes  | Yes     | http://dl.google.com/linux/chrome/rpm/stable/x86_64   
    6 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository      | Yes     | (r ) Yes  | Yes     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                    
    7 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository        | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                      
    localhost:~ #
    
    Besides dvd, I also have source and debug repos. All 3 are not enabled. This all looks good to me. Right?
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: help resolve zypper dup

    Option 1
    To delete the old Ruby and allow the upgrade
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: help resolve zypper dup

    Quote Originally Posted by Prexy View Post
    When I read my own post about repos, I realized that I had the dvd enabled but not in the drive. I disabled the dvd "repo" and ran the zypper dup. The error disappeared. I guess the dvd had priority over the online repos. As mentioned above, TW upgraded to Ruby 2.5. Thanks for trying to help me out
    Quote Originally Posted by Prexy View Post
    I added the last 3 repos after I resolved the error message by disabling the dvd.
    This may not be the case because the dvd repo should have package versions equal or lower than those in online repo so they do not have "priority over the online repos".


    Quote Originally Posted by Prexy View Post
    Besides dvd, I also have source and debug repos. All 3 are not enabled. This all looks good to me. Right?
    Looks good to me.


    Quote Originally Posted by caf4926 View Post
    Option 1
    To delete the old Ruby and allow the upgrade
    This may be the right choice.

    But anyway, your problem is gone. I guess we have no basis for further debugging Have a good day.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: help resolve zypper dup

    Quote Originally Posted by cnzhx View Post
    This may not be the case because the dvd repo should have package versions equal or lower than those in online repo so they do not have "priority over the online repos".
    This is not necessarily true. TW snapshots are integral only to themselves and are not updates, hence version and especially build numbers do not relate between snapshots. There is also the possibility that retaining an old snapshot (DVD) will interfere with the deletion of obsolete packages.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  8. #8

    Default Re: help resolve zypper dup

    Quote Originally Posted by eng-int View Post
    This is not necessarily true. TW snapshots are integral only to themselves and are not updates, hence version and especially build numbers do not relate between snapshots. There is also the possibility that retaining an old snapshot (DVD) will interfere with the deletion of obsolete packages.
    I guess that possibility does exist given that recently the `ucode-intel` is changed from 20180108 to 20171117.

    Sorry to all for my misleading words.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •