Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Cannot Turn Off Firewall In YAST Firewall Section

  1. #1
    Join Date
    Jun 2008
    Location
    Miami, OK
    Posts
    64

    Default Cannot Turn Off Firewall In YAST Firewall Section

    I did a fresh install of Tumbleweed a couple of days ago. Previously, in YAST in the Firewall section, there was an option to merely turn the firewall off. In this new install, I cannot find that option. The firewall is blocking my network printer, scanner and other services, which is truly annoying. I have no idea how to go through and enable all the services necessary to get everything to work with the firewall and wish to just turn it off. Could someone help me figure out how to disable the firewall completely?

    Thanks!
    MSI K9NGM4-V V2
    AMD Athlon 64 X2 4600+(4GB RAM)
    NVIDIA GT218
    Acer P215H
    OpenSUSE Tumbleweed (64 Bit)

  2. #2
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    185

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    Which firewall is installed? SUSEfirewall2 or firewalld or even both?

  3. #3
    Join Date
    Jun 2008
    Location
    Miami, OK
    Posts
    64

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section


    S | Name | Type | Version | Arch | Repository
    ---+------------------+-------------+-------------+--------+------------------------
    i | Firewall | application | | noarch | openSUSE-Tumbleweed-Oss
    i+ | firewall-config | package | 0.4.4.6-4.2 | noarch | openSUSE-Tumbleweed-Oss
    i | firewalld | package | 0.4.4.6-4.2 | noarch | openSUSE-Tumbleweed-Oss
    i | firewalld-lang | package | 0.4.4.6-4.2 | noarch | openSUSE-Tumbleweed-Oss
    i | python3-firewall | package | 0.4.4.6-4.2 | noarch | openSUSE-Tumbleweed-Oss
    i | yast2-firewall | package | 4.0.8-1.2 | noarch | openSUSE-Tumbleweed-Oss

    zenarcher@linux-i7uy:~> systemctl status SuSEfirewall2
    Unit SuSEfirewall2.service could not be found.

    firewalld.service - firewalld - dynamic firewall daemon
    Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: di
    Active: active (running) since Thu 2018-01-25 08:12:32 CST; 5h 43min ago
    Docs: man:firewalld(1)
    Main PID: 805 (firewalld)
    Tasks: 2 (limit: 4915)
    CGroup: /system.slice/firewalld.service
    └─805 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid
    It appears to me that it's firewalld only.
    MSI K9NGM4-V V2
    AMD Athlon 64 X2 4600+(4GB RAM)
    NVIDIA GT218
    Acer P215H
    OpenSUSE Tumbleweed (64 Bit)

  4. #4

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    https://forums.opensuse.org/showthre...=1#post2852614

    ...check in YaST Servie Manager, which firewall is running. Turn off susefirewall2 and turn on firewalld and you can configure it via YaST. Although:

    https://forums.opensuse.org/showthre...ost-recent-dup

    Sorry, I was late. Your problem is not mentioned in any of these threads...
    Kind regards

    raspu

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    185

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    You should be able to start/stop the firewalld service via YAST service manager anytime you want to.

  6. #6

    Default AW: Cannot Turn Off Firewall In YAST Firewall Section

    There currently is no YaST Firewall module, it just starts firewalld's config tool.
    No idea if that allows to turn off the firewall, never used it myself.

    You can stop the firewall with "systemctl stop firewalld.service" or completely disable it with "systemctl disable firewalld.service".
    Or use YaST->System->Services Manager.

  7. #7
    Join Date
    Jun 2008
    Location
    Miami, OK
    Posts
    64

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    Thank you, everyone. I now have the firewall shut off.
    MSI K9NGM4-V V2
    AMD Athlon 64 X2 4600+(4GB RAM)
    NVIDIA GT218
    Acer P215H
    OpenSUSE Tumbleweed (64 Bit)

  8. #8
    Join Date
    Jun 2010
    Location
    Michigan, USA
    Posts
    288

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    Would any moderators / much smarter than me people be opposed to adding information on the openSUSE wiki about Troubleshooting the firewalld?

    https://en.opensuse.org/Firewalld

    When I started the new Firewalld module after the snapshot update, it didn't automatically start / enable firewalld so the module was just spinning waiting to connect.

    Also, the upgrade left the Susefirewall2 active / enabled so perhaps a note about disabling that would be good as well.

    Thoughts?

    -Nathan
    If I am going to be spontaneous, I have to plan for it.

    www.CubicleNate.com

  9. #9

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    Quote Originally Posted by futureboy View Post
    Would any moderators / much smarter than me people be opposed to adding information on the openSUSE wiki about Troubleshooting the firewalld?
    I would not be opposed to that, but I won't do it myself as I don't use Tumbleweed and never used firewalld either...

    When I started the new Firewalld module after the snapshot update, it didn't automatically start / enable firewalld so the module was just spinning waiting to connect.

    Also, the upgrade left the Susefirewall2 active / enabled so perhaps a note about disabling that would be good as well.

    Thoughts?
    Somebody should probably file a bug report about that.
    But I suppose the "migration" is just still work in progress... Or SuSEfirewall2 is left installed/running on purpose to not disrupt people's systems/firewalls when updating.
    And probably firewalld is started fine on a fresh installation, and SuSEfirewall2 not installed at all. Haven't tried that yet though.

  10. #10
    Join Date
    Jun 2010
    Location
    Michigan, USA
    Posts
    288

    Default Re: Cannot Turn Off Firewall In YAST Firewall Section

    I will go ahead and add the information as well as file a bug report. You are probably correct that it was left in place as to not disrupt people's systems when upgrading. I had to set the rules as nothing carried over. No problem though. I know what I've gotten into with Tumbleweed.
    If I am going to be spontaneous, I have to plan for it.

    www.CubicleNate.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •