Results 1 to 10 of 10

Thread: ALSA not activating during boot

  1. #1
    Join Date
    Jul 2008
    Location
    living in the u.s.
    Posts
    116

    Default ALSA not activating during boot

    I've got a startup sound I'd like to play during boot, but ALSA is not getting activated. However, as soon as the system is all up, sound works flawlessly.

    When I go to YAST and look at the startup services, all alsa services are dectivated. When I try to change the status, I get the following message:


    "This service cannot be activated/deactivated because there is no installation segment in the description file."


    Any help is appreciated.

    theo


    openSUSE Leap 42.3 -- KDE-Plasma-Version: 5.8.7 -- Kernel: 4.4.104-39-default -- 64bit

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: ALSA not activating during boot

    I've got a startup sound I'd like to play during boot, but ALSA is not getting activated. However, as soon as the system is all up, sound works flawlessly.
    Where in the boot sequence are you trying to play the startup sound? The ALSA hardware modules are loaded at boot, (but perhaps the level settings are not restored until later in the boot sequence?).

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: ALSA not activating during boot

    Quote Originally Posted by topitz View Post
    When I go to YAST and look at the startup services, all alsa services are dectivated.
    What is reported by the following?
    Code:
    systemctl status alsa-restore
    You should also know that this service is not designed to be enabled by the user. It is called by other units.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: ALSA not activating during boot

    As a test, I just added the following command to /etc/init.d/boot.local
    Code:
    aplay /home/dean/Downloads/my_music.wav 2>&1 >/dev/null &
    and rebooted. A few seconds into the boot sequence, the music started playing.

    Note: For boot.local to be executed, the rc-local service must be enabled.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: ALSA not activating during boot

    Are you just missing the startup sounds??

    Add and change to phonon-backend-vlc

  6. #6

    Default AW: Re: ALSA not activating during boot

    Quote Originally Posted by gogalthorp View Post
    Add and change to phonon-backend-vlc
    Or open ~/.config/plasma_workspace.notifyrc in a text editor and prepend "file://" to the corresponding sound file name.
    I.e. something like:
    Code:
    [Event/startkde]
    Action=Sound
    Execute=
    KTTS=
    Logfile=
    Sound=file:///home/test/Desktop/login.ogg
    TTS=

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: ALSA not activating during boot

    Quote Originally Posted by gogalthorp View Post
    Are you just missing the startup sounds??

    Add and change to phonon-backend-vlc
    I interpreted the OP as perhaps wanting to play some music at boot (prior to X starting even), but perhaps I'm wrong about that.
    Last edited by deano_ferrari; 24-Jan-2018 at 10:46.

  8. #8

    Default Re: ALSA not activating during boot

    Quote Originally Posted by deano_ferrari View Post
    I interpreted the OP as perhaps wanting to play some music at boot (prior to X staring even), but perhaps I'm wrong about that.
    From the OP's post I would think the same.

    But then, what startup sound should there be during boot, before X starts up and the user logs in?

    That "ALSA is not getting activated" is likely just a wrong interpretation on his part anyway, IMHO.
    There are no "alsa services" that would need to be activated to get sound, ALSA is part of the kernel.
    Last edited by wolfi323; 24-Jan-2018 at 10:49.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: ALSA not activating during boot

    Quote Originally Posted by wolfi323 View Post
    From the OP's post I would think the same.

    But then, what startup sound should there be during boot, before X starts up and the user logs in?
    I don't know which is why I asked for clarification, but it is possible

    That "ALSA is not getting activated" is likely just a wrong interpretation on his part anyway, IMHO.
    There are no "alsa services" that would need to be activated to get sound, ALSA is part of the kernel.
    I think because he tried something and there was no sound, he's gone looking for services that might not be enabled - a misapprehension on his part.

  10. #10

    Default Re: ALSA not activating during boot

    Quote Originally Posted by deano_ferrari View Post
    I don't know which is why I asked for clarification, but it is possible
    Sure.
    Clarification is definitely needed here...

    I think because he tried something and there was no sound, he's gone looking for services that might not be enabled - a misapprehension on his part.
    That's what I think as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •