Results 1 to 3 of 3

Thread: World of Warcraft - cannot login

  1. #1

    Unhappy World of Warcraft - cannot login

    Hi,

    Anyone playing WoW on TW here? I got wow successfully installed via Lutris, Battle.net works but when I launch the game it disconnects me instantly with error BLZ51900007.
    I tried creating symlink for ssl certs with:
    Code:
    sudo ln -sf /var/lib/ca-certificates/ca-bundle.pem /etc/ssl/certs/ca-certificates.crt
    That worked for Rocket League but does nothing with WoW.

    Is there any workaround?

    Thanks!

  2. #2

    Default Re: World of Warcraft - cannot login

    I'm quite interested in finding a way to fix this myself as i want to try and start using Tumbleweed as my main distro. I installed World of Warcraft through Lutris which i used the link on their website to find the 1-click installer script. The output from the console is:
    Code:
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:71:36: The style property GtkCheckMenuItem:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    (lutris:9562): Gtk-WARNING **: Theme parsing error: gtk.css:76:30: The style property GtkExpander:expander-size is deprecated and shouldn't be used anymore. It will be removed in a future version
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    wine: Unhandled exception 0xc0000417 in thread 1db at address 0x523586 (thread 01db), starting debugger...
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    ntlm_auth: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference
    I thought it might be related to the firewall as I had to open a few port previously for my steam link to find my computer, but after opening the ports mentioned at blizzards battlenet website related to World of Warcraft. And later disabling the firewall entierly i still get the "You have been disconnected (BLZ51900007)" message.

    I have a seperate install with Arch and there World of Warcraft works just fine using the same Lutris install method and same Wine version. I'm running a completely fresh install of OpenSUSE Tumbleweed using KDE Plasma as the desktop enviorment.

  3. #3

    Default Re: World of Warcraft - cannot login

    OK so after some tinkering i found the solution that works for me, apperantly Lutris has its on runtime. After disabling the Lutris runtime I'm now able to log in.

    Right click World of Warcraft in Lutris -> Configure -> System Options -> Check Disable Lutris Runtime

    If you can't see the option you probably have to check Show advanced options.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •