Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: plasma logins into black screen

  1. #1

    Default plasma logins into black screen

    Hello, update 20180119
    Plasma boots into black screen. I can login into icewm. I tried force reinstall plasma5-workspace as well as plasma patterns. I also tried renaming .kde4 to .kde4_backup but nothing helps.
    Any ideas?

  2. #2

    Default AW: plasma logins into black screen


  3. #3
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    203

    Default Re: plasma logins into black screen

    You need to install Mesa-dri, that should do it. The Mesa driver was split into several packages with one of the latest updates.

    Edit: not fast enough

  4. #4

    Default Re: plasma logins into black screen

    Thank you for your prompt response. I installed Mesa-dri but still get a black screen. I can now open krunner and open konsole but if I try to open plasmashell it crashes right away

  5. #5

    Default Re: plasma logins into black screen

    Quote Originally Posted by WildCowboy View Post
    Thank you for your prompt response. I installed Mesa-dri but still get a black screen. I can now open krunner and open konsole but if I try to open plasmashell it crashes right away
    Then run "zypper dup" to make sure your system is fully up to date.
    Maybe you have a version mix of Mesa packages, like in the other thread.

  6. #6

    Default Re: plasma logins into black screen

    I just did that (ran zypper dup without any options) but it still crashes. Here is konsole output:
    Code:
    file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/FolderItemDelegate.qml:288:17: QML Text: Binding loop detected for property "width"
    file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/FolderItemDelegate.qml:288:17: QML Text: Binding loop detected for property "width"
    file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/FolderItemDelegate.qml:288:17: QML Text: Binding loop detected for property "width"
    qt.svg: <input>:1500:789: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:1500:976: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:1551:795: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:1551:984: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:154:769: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:154:958: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:155:770: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:155:959: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:207:761: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:207:948: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:212:784: Could not add child element to parent element because the types are incorrect.
    qt.svg: <input>:212:974: Could not add child element to parent element because the types are incorrect.
    [KASTATSFAVS]  0x5604fb201850 0x0 "no client ID yet"   initForClient "org.kde.plasma.kicker.favorites.instance-54"
    [KASTATSFAVS]  0x5604fb201850 0x5604fdf08e30 "org.kde.plasma.kicker.favorites.instance-54"   Loading the ordering  ("preferred://browser", "systemsettings.desktop", "org.kde.dolphin.desktop", "org.kde.kate.desktop", "org.kde.konsole.desktop")
    [KASTATSFAVS]  0x5604fb201850 0x5604fdf08e30 "org.kde.plasma.kicker.favorites.instance-54"   Query is Query { Select: LinkedResources, Type: (":any"), Agent: ("org.kde.plasma.favorites.applications", "org.kde.plasma.favorites.contacts", "org.kde.plasma.favorites.documents"), Activity: (":current", ":global"), Url: ("*"), Order: HighScore, Limit: 0 }
    KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory
    KCrash: Attempting to start /usr/bin/plasmashell from kdeinit
    sock_file=/run/user/1000/kdeinit5__0
    KCrash: Application 'plasmashell' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
    sock_file=/run/user/1000/kdeinit5__0
    QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
    QSocketNotifier: Invalid socket 21 and type 'Read', disabling...
    
    [1]+  Stopped                 plasmashell

  7. #7

    Default Re: plasma logins into black screen

    Quote Originally Posted by WildCowboy View Post
    I just did that (ran zypper dup without any options) but it still crashes. Here is konsole output:
    That doesn't tell anything.
    Do you have a backtrace?

    Also, please post the output of glxinfo (you may have to install the package Mesa-demo-x first), the file /var/log/Xorg.0.log, and your repo list:
    Code:
    zypper lr -d

  8. #8

    Default Re: plasma logins into black screen

    here is a list of my repositories:
    Code:
    Repository priorities in effect:                              (See 'zypper lr -P' for details)
          98 (raised priority)  :  1 repository  
          99 (default priority) :  6 repositories
    
    #  | Alias                               | Name                                           | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                              | Service
    ---+-------------------------------------+------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------+--------
     1 | Packman-Repository                  | packman                                        | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/              |        
     2 | home_rawtherapee                    | RawTherapee Home Project (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/home:/rawtherapee/openSUSE_Tumbleweed/ |        
     3 | http-download.opensuse.org-1ff22bf3 | graphics                                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_Factory/             |        
     4 | http-download.opensuse.org-c1ca865f | home:Alexx2000                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Alexx2000/openSUSE_Tumbleweed/   |        
     5 | openSUSE-20170801-0                 | openSUSE-20170801-0                            | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-090c_1000_12052385001327-0:0-part2             |        
     6 | repo-debug                          | openSUSE-Tumbleweed-Debug                      | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                          |        
     7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss                    | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                            |        
     8 | repo-oss                            | openSUSE-Tumbleweed-Oss                        | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                |        
     9 | repo-source                         | openSUSE-Tumbleweed-Source                     | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                         |        
    10 | repo-update                         | openSUSE-Tumbleweed-Update                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                  |
    here is the Xorg log:
    https://drive.google.com/open?id=1nB...Gu1iPEf9G04wtA

    here is glxinfo:
    https://drive.google.com/open?id=1Zo...PE5M5_3v_kEi0C

  9. #9

    Default Re: plasma logins into black screen

    Quote Originally Posted by WildCowboy View Post
    Hm, that looks fine, actually.

    Does it work if you boot with "nomodeset"?

    What about a fresh user account? (or rename ~/.config/, not ~/.kde4 which is/was used by KDE4 as the name implies)

  10. #10

    Default Re: plasma logins into black screen

    Haven't tried nomodeset yet.
    Removing .config folder did not solve the issue. Desktop showed up for a second and then plasma crashed

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •