Results 1 to 6 of 6

Thread: stuck in text mode after boot

  1. #1

    Default stuck in text mode after boot

    Hello.

    Since this morning, after boot, I am stuck in text mode.
    When I type "startx", it fails: see xorg log here and a screen cap here.

    The most strange is that under root, "startx" works and normaly goes in graphical interface. I am writing from the root gui mode (which I do not like).

    I already made a "zypper dup": same problem. I also created a new user: "startx" fail in the same way for this new user...


    Can someone give me a hint to recover the normal behaviour?
    Many thanks.
    Christian

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,916
    Blog Entries
    3

    Default Re: text mode after boot

    Check logs.
    Code:
    journalctl -b
    and see if there is any indication of what caused the problem.

    Maybe also check whether all needed file systems are mounted.
    openSUSE Leap 15.4 Beta; KDE Plasma 5.24.4;
    testing Tumbleweed.

  3. #3

    Default Re : stuck in text mode after boot

    Thank you for your help.

    You know, I am not good at reading such journals, but I do not see anything alaming. It is worth posting the very long journal?
    Moreover, every partition seems properly mouned, everything seems normal.

  4. #4

    Default Re: stuck in text mode after boot

    The error is:
    Code:
    [    34.605] (WW) xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
    [    34.605] (EE) 
    Fatal server error:
    [    34.605] (EE) xf86OpenConsole: Switching VT failed
    (from the Xorg log)

    I would suggest trying to boot the previous kernel, and/or reinstall nvidia-gfxG03-kmp-default.
    Code:
    sudo zypper in -f nvidia-gfxG03-kmp-default
    Or maybe adding your user to the "video" group would help, but that shouldn't be necessary.

    Btw, startx doesn't work as normal user, that's normal.
    X doesn't have necessary privileges then, in particular creating the log file will fail.
    This could be "workarounded" by setting the Xorg executable suid root (as the message tells you), but that's considered to be a security risk.

  5. #5

    Default Re : Re: stuck in text mode after boot

    Quote Originally Posted by wolfi323 View Post

    I would suggest trying to boot the previous kernel, and/or reinstall nvidia-gfxG03-kmp-default.
    Code:
    sudo zypper in -f nvidia-gfxG03-kmp-default
    Or maybe adding your user to the "video" group would help, but that shouldn't be necessary.
    I tried, but unfortunately, it did not fix the problem. Thank you for your help.

  6. #6

    Default Re : stuck in text mode after boot

    Unable to fix the problem, I finaly went back to a 1 week old snapshot via snapper. Works well now.
    Thank you for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •