Results 1 to 4 of 4

Thread: Can't disable USB wakeup

  1. #1

    Default Can't disable USB wakeup

    Trying to hibernate Tumbleweed seems to work (black screen), but then the "screen before the login screen" pops back up - so hibernate fails.

    It seems like it is being woken up right after hibernate. Same two times.

    Swap partition is 8.3G, 8G memory.
    Before hibernating, changed bootloader to

    resume=/dev/mapper/cr_sdb6 splash=silent quiet showopts

    as that is the swap partition name.

    cat /proc/acpi/wakeup
    EHC1 S4 *enabled pci:0000:00:1d.0
    EHC2 S4 *enabled pci:0000:00:1a.0
    XHC S4 *enabled pci:0000:00:14.0

    (rest disabled).

    Trying to disable fails on permission denied:

    sudo echo EHC1 > /proc/acpi/wakeup
    bash: /proc/acpi/wakeup: Permission denied
    echo EHC1 > /proc/acpi/wakeup
    bash: /proc/acpi/wakeup: Permission denied

    What can I do to enable hibernation?

    Is there a good plan B alternative to hibernation?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: Can't disable USB wakeup

    If you're using sudo, try it like this
    Code:
    sudo sh -c 'echo EHC1 > /proc/acpi/wakeup'
    Note: This won't persist through a reboot, so if you need help with making it permanent let us know.

  3. #3

    Default Re: Can't disable USB wakeup

    Thanks.

    I tried just waiting longer and then it seemed to work and has since.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: Can't disable USB wakeup

    Quote Originally Posted by duron600 View Post
    Thanks.

    I tried just waiting longer and then it seemed to work and has since.
    Yep, but you can't use sudo in the way that you were trying to do. It won't persist through a reboot either. It needs to be added via an init script eg boot.local.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •