Results 1 to 2 of 2

Thread: zypper dup: libopenssl-1_0_0_devel-1.0.2n-1.2.x.86_64 conflicts with libopenssl-devel

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default zypper dup: libopenssl-1_0_0_devel-1.0.2n-1.2.x.86_64 conflicts with libopenssl-devel

    Hi,

    for some weeks I get error messages related to openssl when running "zypper dup" on my tumbleweed notebook. This is the output i get:

    Code:
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Problem: libopenssl-1_0_0-devel-1.0.2n-1.2.x86_64 conflicts with libopenssl-devel > 1.0.2n provided by libopenssl-devel-1.1.0g-1.1.noarch
     Solution 1: Following actions will be done:
      keep obsolete libopenssl-1_0_0-devel-1.0.2m-2.1.x86_64
      keep obsolete libopenssl1_0_0-1.0.2m-2.1.x86_64
      keep obsolete openssl-1_0_0-1.0.2m-2.1.x86_64
      keep obsolete libopenssl-devel-1.0.2m-1.1.noarch
      keep obsolete openssl-1.0.2m-1.1.noarch
     Solution 2: Following actions will be done:
      deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
      deinstallation of ca-certificates-2+git20170807.10b2785-4.2.noarch
      deinstallation of kernel-syms-4.14.12-1.5.x86_64
      deinstallation of kernel-syms-4.14.12-1.4.x86_64
      deinstallation of kernel-syms-4.14.9-1.5.x86_64
      deinstallation of ca-certificates-mozilla-2.11-2.1.noarch
      deinstallation of python2-certifi-2017.11.5-1.1.noarch
      deinstallation of python2-requests-2.18.4-1.1.noarch
      deinstallation of python3-certifi-2017.11.5-1.1.noarch
      deinstallation of python3-pip-9.0.1-3.2.noarch
      deinstallation of python3-requests-2.18.4-1.1.noarch
      deinstallation of libpurple-branding-openSUSE-42.2-1.4.noarch
      deinstallation of zypper-migration-plugin-0.10.1488806253.1c712c3-1.3.noarch
      deinstallation of rollback-helper-0.1-2.2.noarch
      deinstallation of system-config-printer-applet-1.5.7-12.2.noarch
      deinstallation of gnome-music-lang-3.26.1-1.2.noarch
     Solution 3: deinstallation of libopenssl-1_0_0-devel-1.0.2m-2.1.x86_64
     Solution 4: keep obsolete libopenssl1_0_0-1.0.2m-2.1.x86_64
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c):
    this is kind of strange because i have a nearly identical installation on my main pc, but did not get this problem there. Anyway, i always choose option 1, hoping the error will go away after a while but i guess this is not happening anymore.

    So what should i do?

  2. #2

    Default Re: zypper dup: libopenssl-1_0_0_devel-1.0.2n-1.2.x.86_64 conflicts with libopenssl-devel

    You cannot have libopenssl-1_0_0_devel and libopenssl-devel (which is 1.1.0 since some time) installed at the same time.

    You probably have some package installed that needed the former in the past and now has been ported to OpenSSL 1.1.0 (one would be libqt4-devel).

    Choose solution 3.
    You only need -devel packages to compile applications yourself, so you probably might also just uninstall it completely...
    Last edited by wolfi323; 22-Jan-2018 at 12:03.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •