Results 1 to 3 of 3

Thread: Cannot add network interfaces in connection details

  1. #1

    Default Cannot add network interfaces in connection details

    In the Virtual Machine Manager, in the Connection Details, in the Network Interfaces tab, there are no interfaces, and the add button is greyed out.
    What's the issue? Do I need to install a package? What's the solution? Is there another setting?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: Cannot add network interfaces in connection details

    Quote Originally Posted by AppCritic View Post
    In the Virtual Machine Manager, in the Connection Details, in the Network Interfaces tab, there are no interfaces, and the add button is greyed out.
    What's the issue? Do I need to install a package? What's the solution? Is there another setting?
    See if this thread helps
    https://forums.opensuse.org/showthre...working-Issues
    and/or this guide
    https://doc.opensuse.org/documentati...bvirt.networks

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Cannot add network interfaces in connection details

    What you're seeing likely resulted because you didn't install virtualization using YaST or didn't agree to the suggestion during install to install a bridge device.
    If you had, br0 would be listed, and it would be configured for ordinary bridging functionality.

    In your situation,
    You should be able to create additional bridging devices representing virtual networks, you can follow the links provided by deano.
    If you had used the YaST virtualization install module to install libvirt, you would see a virbr0 device already, configured for NAT... but disabled by default (Why, I have no idea). The first time you want to use this device to provide NAT networking for your Guests, you have to click the button to "Start Network" and then restart networking manually (eg systemctl restart network).

    So,
    Bottom line is that you should see an Interface listed, and more than likely a bridging device but if you don't, it's not a fatal situation.
    Instead, you should inspect what is listed under the "Virtual Networks" tab and either use anything that already exists or create any kind of virtual network you may want to use.

    BTW -
    I always use the command line to display whatever is available for my Guests, and to double-check any newly created bridge devices are available
    Code:
    brtcl show
    Ideally,
    When you run the above command you should display two interface, a br0 and and a virbr0 which can provide your Guests with network bridging or NAT, respectively.

    I have no idea today why there is both a "Virtual Networks" tab and an "Interfaces" tab...
    The bridge devices created are functionally the same and used the same way in all respects.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •