Results 1 to 7 of 7

Thread: Problem loading firewall

  1. #1

    Default Problem loading firewall

    When I clicked on the firewall icon in Yast this morning, a new package asked to be installed, and when I tried to load the firewall after the install I get the message:

    Code:
    Trying to connect to firewalld, waiting
    I have rebooted the machine, but the same thing happens. I need some help on this matter.

    Dag R

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: Problem loading firewall

    Quote Originally Posted by dagring View Post
    When I clicked on the firewall icon in Yast this morning, a new package asked to be installed, and when I tried to load the firewall after the install I get the message:

    Code:
    Trying to connect to firewalld, waiting
    I have rebooted the machine, but the same thing happens. I need some help on this matter.

    Dag R
    What does the following report?
    Code:
    systemctl status firewalld

  3. #3

    Default Re: Problem loading firewall

    I think it's not running:

    Code:
    dagr@opensuse:~> systemctl status firewalld
    ● firewalld.service - firewalld - dynamic firewall daemon
       Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: disabled)
       Active: inactive (dead)
         Docs: man:firewalld(1)

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: Problem loading firewall

    Ok, so enable the service and start it...
    Code:
    sudo systemctl start firewalld.service
    sudo systemctl enable firewalld.service

  5. #5

    Default Re: Problem loading firewall

    I don't understand how this happened, but when I got the tip from you about status, I went to services and restarted the firewalld. Now it's running fine.

    Thanks a lot.

    Dag R

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: Problem loading firewall

    Good. Happy to have been of help.

  7. #7

    Thumbs up Re: Problem loading firewall

    I ran into the same problem after installing tumbleweed. I followed your advice and was then able to gain access to the firewall applet. Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •