Results 1 to 2 of 2

Thread: trouble accessing samba shares in Dolphin

  1. #1

    Default trouble accessing samba shares in Dolphin

    I am getting a timeout error when trying to access a samba share via Dolphin. Accessing it via the command line works, but only if I use the -m SMB2 or SMB3 options. For example:
    Code:
    smbclient //192.168.1.2/Users -m SMB3
    works, but
    Code:
    smbclient //192.168.1.2/Users
    returns the error:
    Code:
    protocol negotiation failed: NT_STATUS_CONNECTION_RESET
    So, I apparently have to specify the protocol level via the command line to get this to work, but I'd really like to be able to use the graphical interface of Dolphin as well. Any ideas on how to fix this would be much appreciated. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: trouble accessing samba shares in Dolphin

    Quote Originally Posted by z2 View Post
    I am getting a timeout error when trying to access a samba share via Dolphin. Accessing it via the command line works, but only if I use the -m SMB2 or SMB3 options. For example:
    Code:
    smbclient //192.168.1.2/Users -m SMB3
    works, but
    Code:
    smbclient //192.168.1.2/Users
    returns the error:
    Code:
    protocol negotiation failed: NT_STATUS_CONNECTION_RESET
    So, I apparently have to specify the protocol level via the command line to get this to work, but I'd really like to be able to use the graphical interface of Dolphin as well. Any ideas on how to fix this would be much appreciated. Thanks.
    Add the following to the [global] section of /etc/samba/smb.conf
    Code:
    client min protocol = SMB2
    client max protocol = SMB3
    See here:
    https://bugs.kde.org/show_bug.cgi?id=339752
    Last edited by deano_ferrari; 19-Jan-2018 at 02:28.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •