Results 1 to 6 of 6

Thread: btrfs process and desktop slowdown

  1. #1

    Default btrfs process and desktop slowdown

    Hi everyone,
    Since yesterday at least, there are some btrfs processes (btrfs-transacti) which launch after login.
    They use 100% of only one thread, but they slow dramatically and even stall the KDE desktop. The system is unusable for 10mn or so before the btrfs process ends.
    Is there any way to fix this?
    Thanks,
    Andre

  2. #2

    Default Re: btrfs process and desktop slowdown

    Things are getting worse. The btrfs-transacti process now runs at random times and freezes everything.
    This is getting to the point where the KDE desktop is barely usable.
    Am I the only one with this problem?

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: btrfs process and desktop slowdown

    this process runs due to balance (setup by btrfs maintenance) and controlled by systemd timers (sudo systemctl list-timers and look when last balance occurred). On my system it takes about 10 mins to complete. There is a long standing bug on some systems that cause huge duration caused by having quotas enabled. You can google the issue and judge if this is the same symptom and cause.

  4. #4

    Default Re: btrfs process and desktop slowdown

    Thanks for the answer.
    Not sure I understand the whole extent of the explanation, but I have to change laptop soon anyway. I hope things will be better with a fresh installation.

  5. #5
    Join Date
    Jan 2014
    Location
    San Jose City, PH.
    Posts
    118

    Default Re: btrfs process and desktop slowdown

    I was having the same problem, and each day it got exponentially worse, rendering my system unusable moments after the slowdown started. I googled around several symptoms, and found an explanation that it happens after deleting large files, or a large quantity of files.

    The recommended fix was to disable quotas. Some responders questioned why quotas were enabled by default in the first place. So I did these two commands as root since I had deleted a mass of files from both /mnt/BACKUP/ and /home just prior to the beginning of the slowdown:

    Code:
    btrfs quota disable /mnt/BACKUP/
    btrfs quota disable /home
    Now several days have passed without any more slowdowns. For me it solved the problem.
    AMD Ryzen 3 1200 Quad-core Processor, 32MB memory, KDE
    DRIVES: 2 4TB BTRFS raid1, 1 4TB BTRFS for backups

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Cool Re: btrfs process and desktop slowdown

    Quote Originally Posted by techwinder View Post
    Not sure I understand the whole extent of the explanation, but I have to change laptop soon anyway. I hope things will be better with a fresh installation.
    It will possibly not get better: Btrfs needs regular housekeeping, which, at least with openSUSE, only occurs if, the system is continually running -- which, in the case of a Laptop, is possibly not often.

    Therefore, especially for the case of systems which are often shut down, my recommendation is:
    • Occasionally, execute the Btrfs cron jobs in '/etc/cron.weekly/' and '/etc/cron.monthly/' by hand - manually.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •