Results 1 to 3 of 3

Thread: gnome-terminal not launching and Gnome language setting has no effect

  1. #1

    Default gnome-terminal not launching and Gnome language setting has no effect

    Dear all,

    I recently switched from Leap to Tumbleweed. I did a fresh install of the system (keeping only the /home directory as it was on another partition). I am using Gnome 3.26.2. Now, changing the language in Gnome settings does not have any effect on the language used for the GUI. Everything is in english, no matter what language I have chosen. In addition, gnome-terminal does not launch anymore. I found several existing threads suggesting that it has something to do with the locale settings. But, nothing worked so far to resolve this issue.

    The output of locale command (executed in XTerm) is:
    Code:
    locale
    
    LANG=en_US.UTF-8
    LC_CTYPE="C"
    LC_NUMERIC="C"
    LC_TIME="C"
    LC_COLLATE="C"
    LC_MONETARY="C"
    LC_MESSAGES="C"
    LC_PAPER="C"
    LC_NAME="C"
    LC_ADDRESS="C"
    LC_TELEPHONE="C"
    LC_MEASUREMENT="C"
    LC_IDENTIFICATION="C"
    LC_ALL=C
    The output of locale -a is:
    Code:
    locale -a | grep en_US
    
    en_US
    en_US.iso885915
    en_US.utf8
    The output of localectl is:
    Code:
    localectl
    
    System Locale: LANG=en_US.UTF-8
    VC Keymap: de-nodeadkeys
    X11 Layout: de
    X11 Model: microsoftpro
    X11 Variant: nodeadkeys
    X11 Options: terminate:ctrl_alt_bksp
    When trying to start gnome-terminal from XTerm I get:
    Code:
    gnome-terminal
    
    Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached
    I have a second user, where everything works fine. I can switch the language to German and also the terminal launches. So, I guess this must have something to do with a user setting and not a system wide setting.

    I would be happy about any help on this issue.

  2. #2

    Default Re: gnome-terminal not launching and Gnome language setting has no effect

    I'm having this exact same issue in Oct'18

    "dbus-launch gnome-terminal" is one work-around.

  3. #3

    Default Re: gnome-terminal not launching and Gnome language setting has no effect

    Solution

    Code:
    mv ~/.config/dconf/user ~/.config/dconf/user.old
    It's a binary file, and I have no idea how to inspect it.
    Then gnome-terminal launches on Tumbleweed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •