Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to save settings in xinput in Opensuse leap 42.3

  1. #1

    Default How to save settings in xinput in Opensuse leap 42.3

    Hi,

    I use xinput to change properties of my mouse. But after reboot, all changes were lost.

    I ever tried /etc/init.d/after.local, but it doesn’t work.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,539
    Blog Entries
    1

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by sincos2007 View Post
    Hi,

    I use xinput to change properties of my mouse. But after reboot, all changes were lost.

    I ever tried /etc/init.d/after.local, but it doesn’t work.

    Thanks.
    That's because they need to be executed with an active X-session running. Instead, you could add the commands within your user's X-session by running them via a desktop 'autostart' file.

    https://wiki.archlinux.org/index.php...esktop_entries

  3. #3

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Another option would be to add them to the X startup scripts.
    E.g. /etc/X11/xdm/Xsession is run to start the user session (and desktop), and /etc/X11/xdm/Xsetup is run when the graphical display is set up, i.e. this will also affect the login screen.

    Or ~/.xinitrc, which is also executed when the X user session starts (system-wide location: /etc/X11/xinit/)

  4. #4

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    I have created the .desktop file to execute xinput and set the desktop file as running at system boot. Ok, I get settings when I reboot the system. But when I created the desktop file to execute xset m 100, I still lost my settings when I reboot.

  5. #5

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by sincos2007 View Post
    But when I created the desktop file to execute xset m 100, I still lost my settings when I reboot.
    What desktop are you using?
    It might override the mouse acceleration settings with its own.

  6. #6

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    My desktop is gnome.

  7. #7

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by sincos2007 View Post
    My desktop is gnome.
    Then I would suggest trying to change the mouse speed/acceleration in gnome-control-center.

  8. #8

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by wolfi323 View Post
    Then I would suggest trying to change the mouse speed/acceleration in gnome-control-center.
    There is no mouse configuration entry in mouse and touchpad under gnome-control-center.

  9. #9

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by sincos2007 View Post
    There is no mouse configuration entry in mouse and touchpad under gnome-control-center.
    You mean it looks different than mine?



    I'm not using GNOME, so probably cannot help you there though.
    But I am using Leap 42.3...

    Maybe try adding a delay to your xset call, something like this:
    Code:
    sleep 5; xset -m 100
    What changes did you do exactly?
    Maybe you made a mistake and xset is not run at all.
    (I suppose it works if you run xset manually...)
    Last edited by wolfi323; 17-Jan-2018 at 13:01.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,539
    Blog Entries
    1

    Default Re: How to save settings in xinput in Opensuse leap 42.3

    Quote Originally Posted by sincos2007 View Post
    There is no mouse configuration entry in mouse and touchpad under gnome-control-center.
    Is the libinput driver managing your touchpad device? Check via the Xorg log eg
    Code:
    grep "Using input driver" /var/log/Xorg.0.log

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •