Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: leap 42.2 kde network manager does not remember wifi password

  1. #1
    Peter_Abc NNTP User

    Default leap 42.2 kde network manager does not remember wifi password

    Hi openSuse forum support team,

    My problem is that I have an Optus 4G Wingle modem setup with hidden
    ssid and network manger keeps asking for the password every time it
    disconnects (i.e. I start/restart commuter or from sleep mode). how can
    I make NM to remember password?

    Thanks in advance for any help in resolving this issue.

    Cheers,
    Peter

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: leap 42.2 kde network manager does not remember wifi password

    I assume the is kwallet. You can set it's password to blank and it won't ask any more.

  3. #3
    Peter_Abc NNTP User

    Default Re: leap 42.2 kde network manager does not remember wifi password

    On 16/01/18 14:06, gogalthorp wrote:
    >
    > I assume the is kwallet. You can set it's password to blank and it won't
    > ask any more.


    I have kwallet disabled in KWallet Configuration but I think I tried the
    blank password option and it refused to remember my password.

    I am looking for an easy solution right now as I don't have the time and
    energy (due to personal serious health issues) to try various options.

    Cheers

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: leap 42.2 kde network manager does not remember wifi password

    Quote Originally Posted by Peter_Abc View Post

    I am looking for an easy solution right now as I don't have the time and
    energy (due to personal serious health issues) to try various options.

    Cheers
    Can you not set it up as a system-wide connection?

  5. #5
    Peter_Abc NNTP User

    Default Re: leap 42.2 kde network manager does not remember wifi password

    On 16/01/18 15:16, deano ferrari wrote:
    >
    > Peter_Abc;2851403 Wrote:
    >>
    >>
    >> I am looking for an easy solution right now as I don't have the time and
    >> energy (due to personal serious health issues) to try various options.
    >>
    >> Cheers

    > Can you not set it up as a system-wide connection?


    It will not let me now since I made my main user account the one that
    controls the connecting. But before I did that, I tried all the normal
    things that worked with other connections (but not hidden ssid) and had
    no luck. I recreated the connection several times and same result.

    Lastly I will try to unhide the ssid temporarily and see if it will
    remember the password that way.


    Cheers


  6. #6
    Peter_Abc NNTP User

    Default Re: leap 42.2 kde network manager does not remember wifi password

    On 16/01/18 15:16, deano ferrari wrote:
    >
    > Peter_Abc;2851403 Wrote:
    >>
    >>
    >> I am looking for an easy solution right now as I don't have the time and
    >> energy (due to personal serious health issues) to try various options.
    >>
    >> Cheers

    > Can you not set it up as a system-wide connection?

    I was able to do that now, after re-entering the password again, but now
    it asks for root password + wifi password at every connection (now on
    unhidden ssid too).

    Cheers

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: leap 42.2 kde network manager does not remember wifi password

    Quote Originally Posted by Peter_Abc View Post
    On 16/01/18 15:16, deano ferrari wrote:
    >
    > Peter_Abc;2851403 Wrote:
    >>
    >>
    >> I am looking for an easy solution right now as I don't have the time and
    >> energy (due to personal serious health issues) to try various options.
    >>
    >> Cheers

    > Can you not set it up as a system-wide connection?

    I was able to do that now, after re-entering the password again, but now
    it asks for root password + wifi password at every connection (now on
    unhidden ssid too).

    Cheers
    That doesn't make sense to me. I have a wireless connection configured with "All users may connect to this network" and the connection profile looks like this
    Code:
    [connection]
    id=TCL
    uuid=82510ee7-f711-472f-bf4d-404cd2750d1d
    type=wifi
    autoconnect-priority=-10
    permissions=
    secondaries=
    
    [wifi]
    mac-address=xx:xx:xx:xx:xx:xx
    mac-address-blacklist=
    mode=infrastructure
    seen-bssids=
    ssid=TCL***
    
    [wifi-security]
    group=
    key-mgmt=wpa-psk
    pairwise=
    proto=
    psk=********
    
    [ipv4]
    dns-search=
    method=auto
    
    [ipv6]
    dns-search=
    method=auto
    The connection credentials are in the file itself. No manual authentication needed.

  8. #8
    Peter_Abc NNTP User

    Default Re: leap 42.2 kde network manager does not remember wifi password

    On 16/01/18 20:46, deano ferrari wrote:
    >
    > Peter_Abc;2851411 Wrote:
    >> On 16/01/18 15:16, deano ferrari wrote:
    >>>
    >>> Peter_Abc;2851403 Wrote:
    >>>>
    >>>>
    >>>> I am looking for an easy solution right now as I don't have the time

    >> and
    >>>> energy (due to personal serious health issues) to try various

    >> options.
    >>>>
    >>>> Cheers
    >>> Can you not set it up as a system-wide connection?

    >> I was able to do that now, after re-entering the password again, but now
    >> it asks for root password + wifi password at every connection (now on
    >> unhidden ssid too).
    >>
    >> Cheers

    > That doesn't make sense to me. I have a wireless connection configured
    > with "All users may connect to this network" and the connection profile
    > looks like this
    >
    > Code:
    > --------------------
    >
    > [connection]
    > id=TCL
    > uuid=82510ee7-f711-472f-bf4d-404cd2750d1d
    > type=wifi
    > autoconnect-priority=-10
    > permissions=
    > secondaries=
    >
    > [wifi]
    > mac-address=xx:xx:xx:xx:xx:xx
    > mac-address-blacklist=
    > mode=infrastructure
    > seen-bssids=
    > ssid=TCL***
    >
    > [wifi-security]
    > group=
    > key-mgmt=wpa-psk
    > pairwise=
    > proto=
    > psk=********
    >
    > [ipv4]
    > dns-search=
    > method=auto
    >
    > [ipv6]
    > dns-search=
    > method=auto
    > --------------------
    >
    > The connection credentials are in the file itself. No manual
    > authentication needed.
    >

    It is working now (after I reactivated KWallet) and connection
    credentials are as below:

    [connection]
    id=XYZ
    uuid=743fedc7-0e9d-40ba-8b5f-5d942de67161
    tfor youype=wifi
    permissions=user:xxxxuser:;
    secondaries=

    [wifi]
    mac-address=xxxxxxxx
    mac-address-blacklist=
    mode=infrastructure
    seen-bssids=
    ssid=XYZ

    [wifi-security]
    auth-alg=open
    group=
    key-mgmt=wpa-psk
    pairwise=
    proto=
    psk-flags=1

    [ipv4]
    dns-search=
    method=auto

    [ipv6]
    dns-search=
    method=

    It took some time and a few restarts before finally connecting
    automatically without asking for wifi password. Though I have yet to try
    with ssid hidden.

    Thanks for your effort in trying to solve this issue.

    Cheers

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: leap 42.2 kde network manager does not remember wifi password

    Quote Originally Posted by Peter_Abc View Post

    It took some time and a few restarts before finally connecting
    automatically without asking for wifi password. Though I have yet to try
    with ssid hidden.

    Thanks for your effort in trying to solve this issue.

    Cheers
    Ok, but your connection is defined as a 'user' connection, with secrets stored in kwallet. I was proposing to use a 'system' connection ('All users may connect to this network') where kwallet is not used.
    Last edited by deano_ferrari; 17-Jan-2018 at 22:38.

  10. #10
    Peter_Abc NNTP User

    Default Re: leap 42.2 kde network manager does not remember wifi password

    On 18/01/18 16:46, deano ferrari wrote:
    >
    > Peter_Abc;2851651 Wrote:
    >>
    >>
    >> It took some time and a few restarts before finally connecting
    >> automatically without asking for wifi password. Though I have yet to try
    >> with ssid hidden.
    >>
    >> Thanks for your effort in trying to solve this issue.
    >>
    >> Cheers

    > Ok, but your connection is defined as a 'user' connection, with secrets
    > stored in kwallet. I was proposing to use a 'system' connection ('All
    > users may connect to this network') where kwallet is not used.
    >
    >

    I am undergoing radiation and chemo treatment in the next 4 weeks and do
    not have the energy and time to try various options. I have another
    partition with 42.3 and wifi connections there work fine but there are
    other issues I need to look into after my medical treatment is complete
    and the side effects ease up a bit.

    Cheers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •