Results 1 to 3 of 3

Thread: Upgrade UEFI machine from 42.2 will not boot

  1. #1

    Default Upgrade UEFI machine from 42.2 will not boot

    I have successfully upgraded two machines using a USB download of Leap 42.3 however both of them do not have UEFI. Today I did the upgrade on the only machine which has UEFI (an HP mini tower). This machine has been running Leap 42.2 for six or seven months without any issues, and it is the only operating system on the disk. Also, secure boot is disabled and legacy is enabled.

    Apart from the problem with the boot loader putting two entries into the device.map file the upgrade went through apparently OK but now the system will not boot. However if I run up the rescue system I can mount the new system and do the mounts which allow me to run it from chroot and it all seems to be working OK.

    I've tried running Yast to reconfigure the loader, using grub2-efi, and that all seems to behave as I would expect but still no boot. If I let the USB key start up and tell it to boot from HD then I get an error '/efi/boot/fallback.efi has not been found'. If I go into the boot menu and tell it to boot directly from the disk I get the error 'No boot disk has been detected or the disk has failed'. I have even got yast to reconfigure to non-EFI and told the BIOS to boot legacy - same again.

    I have tried a specific efi configuration specifying grub64.efi

    I also tried to use the facility on the USB key to run the system but that goes through all the questions and eventually comes up with a screen which has a heading which seems to indicate it knows what it is trying to run but nothing happens.

    I am currently at a complete loss to know where the problem exists. As I'm not even getting a grub menu there is something fairly basic wrong with my configuration but I cannot see what it is so any help would really be appreciated.

  2. #2

    Default Re: Upgrade UEFI machine from 42.2 will not boot

    I didn't really get to the bottom of this. I tried using a spare disk and doing a clean install and then copying things from this disk to the one that wasn't working. No joy. What I eventually noticed was that whatever efibootmgr put into nvram it changed when the system rebooted. The entry lost the pointer to a disk and became venhw(...) and this does not happen on a clean system. I eventually resorted to performing a clean install and all is now working but I really would like to understand what went wrong so that I can potentially avoid the same problem in the future.

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Upgrade UEFI machine from 42.2 will not boot

    Perhaps a broken UEFI.

    There have been report that some hardware's UEFI will insist o n booting Windows. Perhaps look for an UEFI/BIOS update

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •