Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Graphical interface on tty1

  1. #1
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    222

    Default Graphical interface on tty1

    I don't get this, my graphical interface is on tty1 and not tty7 as it is on every other SuSE/openSUSE box I've ever built (and I'm going back to SuSE 4 at least).

    It's a UEFI dual boot system with Windoze 10 and openSUSE Leap 42.3 and an NVidia GTX 970 graphics card.
    I had real problems trying to install Leap 42.3 as it kept hanging at 'starting udev' and ended up installing 42.2 which worked and then updating to 42.3 via zypper dup.

    I've got another PC set up as UEFI dual boot Windoze 10 and openSUSE Leap 42.3 which installed without a hitch (without the GTX 970) and that has the graphical interface on tty7

    Have I managed to change some configuration setting by accident and how do I put it back?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: Graphical interface on tty1

    Quote Originally Posted by fudokai View Post
    I don't get this, my graphical interface is on tty1 and not tty7 as it is on every other SuSE/openSUSE box I've ever built (and I'm going back to SuSE 4 at least).
    Hmmm....just an idea (so apologies if I'm on the wrong track here)...how is 'NAutoVTs=' configured in /etc/systemd/logind.conf?

    From 'man logind.conf'
    NAutoVTs=
    Takes a positive integer. Configures how many virtual terminals (VTs) to allocate by default that, when switched to and are
    previously unused, "autovt" services are automatically spawned on. These services are instantiated from the template unit
    autovt@.service for the respective VT TTY name, for example, autovt@tty4.service. By default, autovt@.service is linked to
    getty@.service. In other words, login prompts are started dynamically as the user switches to unused virtual terminals.
    Hence, this parameter controls how many login "gettys" are available on the VTs. If a VT is already used by some other
    subsystem (for example, a graphical login), this kind of activation will not be attempted. Note that the VT configured in
    ReserveVT= is always subject to this kind of activation, even if it is not one of the VTs configured with the NAutoVTs=
    directive. Defaults to 6. When set to 0, automatic spawning of "autovt" services is disabled.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: Graphical interface on tty1

    Can you show us output of the following please?
    Code:
    ps aux|grep /usr/bin/[X]

  4. #4
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: Graphical interface on tty1

    Quote Originally Posted by fudokai View Post
    I don't get this, my graphical interface is on tty1 and not tty7 as it is on every other SuSE/openSUSE box
    What DM are you using?

  5. #5
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    222

    Default Re: Graphical interface on tty1

    Quote Originally Posted by deano_ferrari View Post
    Hmmm....just an idea (so apologies if I'm on the wrong track here)...how is 'NAutoVTs=' configured in /etc/systemd/logind.conf?

    From 'man logind.conf'
    It looks like NAutoVTs is set to the default (6)
    Code:
    ~> cat /etc/systemd/logind.conf
    #  This file is part of systemd.
    #
    #  systemd is free software; you can redistribute it and/or modify it
    #  under the terms of the GNU Lesser General Public License as published by
    #  the Free Software Foundation; either version 2.1 of the License, or
    #  (at your option) any later version.
    #
    # Entries in this file show the compile time defaults.
    # You can change settings by editing this file.
    # Defaults can be restored by simply deleting this file.
    #
    # See logind.conf(5) for details.
    
    [Login]
    #NAutoVTs=6
    However ...
    Code:
    ~> ps aux|grep /usr/bin/[X]
    root      3770  8.3  0.4 208660 79644 ?        Ss   09:24   0:16 /usr/bin/X -nolisten tcp -auth /run/sddm/{5e598f7b-cbd5-40ef-9089-d3e05ba89a98} -background none -noreset -displayfd 21 vt1

  6. #6
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    222

    Default Re: Graphical interface on tty1

    Quote Originally Posted by arvidjaar View Post
    What DM are you using?
    DM? Sorry, you'll need to translate that

    If you mean device mapper, I've got /boot on an ext4 partition and everything else (/ and swap) on LVM except /home on ntfs if that helps

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: Graphical interface on tty1

    However ...
    Code:
    ~> ps aux|grep /usr/bin/[X]
    root      3770  8.3  0.4 208660 79644 ?        Ss   09:24   0:16 /usr/bin/X -nolisten tcp -auth /run/sddm/{5e598f7b-cbd5-40ef-9089-d3e05ba89a98} -background none -noreset -displayfd 21 vt1
    Please show us
    Code:
    cat /etc/sddm.conf

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: Graphical interface on tty1

    Quote Originally Posted by fudokai View Post
    DM? Sorry, you'll need to translate that

    If you mean device mapper, I've got /boot on an ext4 partition and everything else (/ and swap) on LVM except /home on ntfs if that helps
    No, he meant display manager, and the output already answers that: sddm

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: Graphical interface on tty1

    I assume that you're missing the 'MinimumVT=' option. The default is 1. Refer 'man sddm.conf' for more info.

    For reference, I have
    Code:
    MinimumVT=7

  10. #10
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    222

    Default Re: Graphical interface on tty1

    Quote Originally Posted by deano_ferrari View Post
    I assume that you're missing the 'MinimumVT=' option. The default is 1. Refer 'man sddm.conf' for more info.

    For reference, I have
    Code:
    MinimumVT=7
    Interesting ... What I have for sddm.conf is
    Code:
    [Theme]
    
    [XDisplay]
    but I do have sddm.conf.rpmnew which looks like this
    Code:
    [Theme]
    Current=
    CursorTheme=breeze_cursors
    
    [XDisplay]
    ServerPath=/usr/bin/X
    SessionCommand=/etc/X11/xdm/Xsession
    DisplayCommand=/etc/X11/xdm/Xsetup
    MinimumVT=7
    I've added MinimumVT=7, rebooted and that's sorted it - thanks.

    Looking at a couple of other machines ...
    One, which was an upgrade from 42.2, has an empty sddm.conf and another which was an install of 42.3 has sddm.conf as the sddm.conf.rpmnew above.

    I'll try setting sddm.conf.rpmnew as sddm.conf later and try a reboot with that.

    I can't think of anything I did during the build to change sddm.conf (at least not directly) - do think I should report this as a bug?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •