Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Can't boot latest kernel 4.14.12-1-default

  1. #1

    Default Can't boot latest kernel 4.14.12-1-default

    I recently installed latest software update but it doesn't boot normally.

    It boots to ALT+F1 screen and when I press ALT+F7 to go to login screen there is just bunch of messages which starts with it stucks on that screen:

    https://imgur.com/pAtm10a

    What should I do?

  2. #2

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Quote Originally Posted by Bastago View Post
    What should I do?
    Boot the previous kernel (select it in "Advanced Options" in the boot menu), and wait for the next kernel update (or install 4.14.13 from Kernel:stable).

    If you have Teamviewer installed, uninstall or disable it, and 4.14.12 might boot too.

  3. #3

    Default Re: Can't boot latest kernel 4.14.12-1-default

    I exactly did what you said actually. Kernel 4.14.9-1-default wasn't booting and I kept using 4.14.8-1 for a while. Today I updated it to 4.14.12-1 and now I can't go back to 4.14.8-1 which is the only kernel that works.

  4. #4

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Quote Originally Posted by Bastago View Post
    I exactly did what you said actually. Kernel 4.14.9-1-default wasn't booting and I kept using 4.14.8-1 for a while. Today I updated it to 4.14.12-1 and now I can't go back to 4.14.8-1 which is the only kernel that works.
    Well, that's bad.
    And your problems are not related to the recent security fixes then either.

    Unfortunately your screenshots give absolutely no clue what may be wrong.

    What display manager and graphics card are you using?
    Does the system boot to a text mode if you add '3' or '1' to the kernel boot options? (press 'e' at the boot menu and append that at the end of the line starting with "linux" or "linuxefi")

    If yes, try to switch the display manager to xdm with "sudo update-alternatives --config default-displaymanager", and see if the system boots to graphics mode then.

    Also try to boot with "nomodeset" maybe.

  5. #5

    Default Re: Can't boot latest kernel 4.14.12-1-default

    I tried changing it to xdm and booting with nomodeset but nothing changed

  6. #6
    Join Date
    Sep 2012
    Posts
    7,105

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Quote Originally Posted by Bastago View Post
    I tried changing it to xdm
    How exactly did you change to xdm if you cannot boot?

  7. #7

    Default Re: Can't boot latest kernel 4.14.12-1-default

    If you read my post it says it boots to alt+f1 screen and when I press alt+f7 the screen on the imgur link appears. So I can run terminal commands.

  8. #8

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Quote Originally Posted by Bastago View Post
    If you read my post it says it boots to alt+f1 screen and when I press alt+f7 the screen on the imgur link appears. So I can run terminal commands.
    So does that mean you DO get a text mode login prompt when booting?
    Just the graphical session doesn't start and if you switch to VT-7 (i.e. press Alt+F7) there are just text messages, no login screen?

    In that case, please provide the output of "systemctl get-default".

  9. #9

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Ok I ran the "systemctl get-default" command and the output is "graphical.target"

  10. #10

    Default Re: Can't boot latest kernel 4.14.12-1-default

    Quote Originally Posted by Bastago View Post
    Ok I ran the "systemctl get-default" command and the output is "graphical.target"
    That looks fine.

    So the system does boot to a text mode login prompt?

    What does "sudo systemctl status display-manager" say?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •