Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: DE switch failed, Tumblewees now wont booy

  1. #1

    Exclamation DE switch failed, Tumblewees now wont booy

    I have the latest version of Tumbleweed GNOME installed, and I tried to switch to LXDE by using the config editor in YaST. However, I didn't have LXDE installed, and now Tumbleweed is stuck at "boot job running for Halt until startup is finished (xx/xx)".

    Can anyone help me reconfigure my config file/ install LXDE please?

  2. #2

    Default Re: DE switch failed, Tumblewees now wont booy

    Quote Originally Posted by rhyshowells26 View Post
    I have the latest version of Tumbleweed GNOME installed, and I tried to switch to LXDE by using the config editor in YaST.
    And what exactly did you change in YaST?

    Btw, you can just choose a different desktop on the login screen, no need to change anything in YaST (you may have to install the other desktop first though, of course).

    However, I didn't have LXDE installed, and now Tumbleweed is stuck at "boot job running for Halt until startup is finished (xx/xx)".
    That rather sounds like you changed the default boot target, and the system is trying to boot to "Halt" now (which means shutdown without powering off) instead of the graphical.target.

    Press 'e' at the boot menu and append '5' to the line starting with "linux" or "linuxefi".
    Does the system boot correctly then?
    Last edited by wolfi323; 13-Jan-2018 at 06:02.

  3. #3

    Default Re: DE switch failed, Tumblewees now wont booy

    Sorry, still not booting. I used the /etc/YaST/config option in the YaST client.

  4. #4

    Default Re: DE switch failed, Tumblewees now wont booy

    Quote Originally Posted by rhyshowells26 View Post
    Sorry, still not booting.
    Same error?

    I used the /etc/YaST/config option in the YaST client.
    But what did you change exactly?

    The DEFAULT_WM option (that specifies the desktop that's used by default) should not cause this at all.

    Does it boot to a text mode login prompt if you add '3' or '1' (as before)?
    And just to avoid a possible misunderstanding: you need to append a space before the number as well.
    Last edited by wolfi323; 13-Jan-2018 at 07:36.

  5. #5

    Default Re: DE switch failed, Tumblewees now wont booy

    Yep, DEFAULT_WM. Same error too

  6. #6

    Default Re: DE switch failed, Tumblewees now wont booy

    Quote Originally Posted by rhyshowells26 View Post
    Yep, DEFAULT_WM.
    Nothing else?
    Well, revert your change by modifying /etc/sysconfig/windowmanager with a text editor.

    Either use a LiveCD, or add "init=/bin/sh" to the boot options to get to a minimal text mode system.

    But as I said, IMHO that change cannot really cause your problem so reverting it probably won't help either.

    Maybe post a screenshot/photograph of your error, there might be some other clue on the screen...
    There normally shouldn't be a boot job for Halt running at all IMHO.

  7. #7

    Default Re: DE switch failed, Tumblewees now wont booy

    Boot now stuck at "Reached target Local File Systems (Pre).

  8. #8

    Default Re: DE switch failed, Tumblewees now wont booy

    Quote Originally Posted by rhyshowells26 View Post
    Boot now stuck at "Reached target Local File Systems (Pre).
    And what did you change?

    Can you get to a text mode login by pressing Ctrl+Alt+F1?

  9. #9

    Default Re: DE switch failed, Tumblewees now wont booy

    Nope, just shows "Failed to start Setup Virtual Console. See 'systemctl status systemd-vconsole-setup.service' for details. Starting Show Plymoth Boot Screen..." . Added 5 to the end of linuxefi line as you said

  10. #10

    Default Re: DE switch failed, Tumblewees now wont booy

    Quote Originally Posted by rhyshowells26 View Post
    Nope, just shows "Failed to start Setup Virtual Console. See 'systemctl status systemd-vconsole-setup.service' for details. Starting Show Plymoth Boot Screen..." .
    Try adding "plymouth.enable=0" then.
    Does that help?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •