Results 1 to 7 of 7

Thread: Can't update because of ibus-gtk-32bit

  1. #1

    Default Can't update because of ibus-gtk-32bit

    Hello, I can't update since 2 days...

    Checking for file conflicts: .....................................................[done]
    ( 1/241) Removing ibus-gtk-32bit-1.5.17-1.2.x86_64 .............................[error]
    Removal of (64204)ibus-gtk-32bit-1.5.17-1.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: /usr/bin/gtk-query-immodules-2.0: error while loading shared libraries: libpixman-1.so.0: cannot open shared object file: No such file or directory
    error: %preun(ibus-gtk-32bit-1.5.17-1.2.x86_64) scriptlet failed, exit status 127
    error: ibus-gtk-32bit-1.5.17-1.2.x86_64: erase failed

    Abort, retry, ignore? [a/r/i] (a):

    What can I do now ?
    thanks you

  2. #2

    Default Re: Can't update because of ibus-gtk-32bit

    Apparently gtk2-tools-32bit hasn't been updated in the repo.
    That's not the only problem with TW 32bit at the moment... (see https://forums.opensuse.org/showthre...ing-zypper-dup )

    Seems like something went wrong with publishing the (32bit) snapshot, at least some of the packages are outdated and haven't been updated which causes dependency problems.

    I suppose it will be fixed soon (with the next snapshot at the latest), for now I suppose you could just uninstall ibus-gtk-32bit, it's only necessary to use ibus in 32bit GTK applications (I think).

  3. #3
    Join Date
    Feb 2017
    Location
    Very Far Away
    Posts
    67

    Default Re: Can't update because of ibus-gtk-32bit

    I had a similar problem yesterday, and managed to solve it by re-installing the offending library (in your case it would be libpixman, I believe) and then retrying to update ibus-gtk.

  4. #4

    Default AW: Can't update because of ibus-gtk-32bit

    Quote Originally Posted by wolfi323 View Post
    Apparently gtk2-tools-32bit hasn't been updated in the repo.
    That's not the only problem with TW 32bit at the moment... (see https://forums.opensuse.org/showthre...ing-zypper-dup )

    Seems like something went wrong with publishing the (32bit) snapshot, at least some of the packages are outdated and haven't been updated which causes dependency problems.
    Although, I just had a look and gtk2-tools-32bit has been updated and the package in the repo doesn't require libpixman.so.1 anymore.

    Just to be sure: you are using "zypper dup", right?
    That's the only recommended (and supported) way to update Tumbleweed.

    Quote Originally Posted by Icearchery View Post
    I had a similar problem yesterday, and managed to solve it by re-installing the offending library (in your case it would be libpixman, I believe) and then retrying to update ibus-gtk.
    libpixman-1-0-32bit to be exact.
    Yes, that should "fix" the problem as well.

    But should not be necessary, as the latest gtk2-tools-32bit package (and the /usr/bin/gtk-query-immodules-2.0 it contains) does not require it anymore.
    It may be a problem with the package install/uninstall order though...
    Last edited by wolfi323; 13-Jan-2018 at 05:57.

  5. #5

    Default Re: AW: Can't update because of ibus-gtk-32bit

    OK thanks for getting me on the right way, I installed :

    libpixman-1-0-32bit
    libxcb-shm0-32bit
    libxcb-render0-32bit

    and it works now, my
    "sudo zypper dup" is going fine !

    Thanks you very much

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,819

    Default Re: Can't update because of ibus-gtk-32bit

    Nice it is solved.

    Please next time when posting computer text as in the first post here, use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    Including the prompts and the command then will make such questions as wolfie323 did
    Just to be sure: you are using "zypper dup", right?
    superfluous.
    Henk van Velden

  7. #7

    Default Re: Can't update because of ibus-gtk-32bit

    OK, sorry, I will do it next time.

    thanks all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •