Results 1 to 7 of 7

Thread: Calibre doesn't launch

  1. #1

    Default Calibre doesn't launch

    Hello.
    When I was installing Calibre I read that nothing provide libicui18n.so.59.1. I installed without this dependency. The system has installed libicui18n.so.60_2 but Calibre doesn't work.
    Code:
    Traceback (most recent call last):
      File "/usr/bin/calibre", line 19, in <module>
        from calibre.gui_launch import calibre
      File "/usr/lib64/calibre/calibre/__init__.py", line 22, in <module>
        from calibre.startup import winutil, winutilerror
      File "/usr/lib64/calibre/calibre/startup.py", line 151, in <module>
        from calibre.utils.icu import title_case, lower as icu_lower, upper as icu_upper
      File "/usr/lib64/calibre/calibre/utils/icu.py", line 27, in <module>
        raise RuntimeError('Failed to load icu with error: %s' % err)
    RuntimeError: Failed to load icu with error: libicui18n.so.59.1: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
    /usr/lib64/calibre/calibre/ptempfile.py:29: RuntimeWarning: Parent module 'calibre' not found while handling absolute import
      import shutil
    Any idea.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,100
    Blog Entries
    15

    Default Re: Calibre doesn't launch

    Quote Originally Posted by r0mp3t3ch0s View Post
    Hello.
    When I was installing Calibre I read that nothing provide libicui18n.so.59.1. I installed without this dependency. The system has installed libicui18n.so.60_2 but Calibre doesn't work.
    Code:
    Traceback (most recent call last):
      File "/usr/bin/calibre", line 19, in <module>
        from calibre.gui_launch import calibre
      File "/usr/lib64/calibre/calibre/__init__.py", line 22, in <module>
        from calibre.startup import winutil, winutilerror
      File "/usr/lib64/calibre/calibre/startup.py", line 151, in <module>
        from calibre.utils.icu import title_case, lower as icu_lower, upper as icu_upper
      File "/usr/lib64/calibre/calibre/utils/icu.py", line 27, in <module>
        raise RuntimeError('Failed to load icu with error: %s' % err)
    RuntimeError: Failed to load icu with error: libicui18n.so.59.1: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
    /usr/lib64/calibre/calibre/ptempfile.py:29: RuntimeWarning: Parent module 'calibre' not found while handling absolute import
      import shutil
    Any idea.
    Hi
    It would appear to be broken in the development repo;
    https://build.opensuse.org/package/b...USE_Tumbleweed

    Since it still wants that lib and another;
    Code:
    libicui18n.so.59.1()(64bit)
    libicuuc.so.59.1()(64bit)
    Looks like it's also missing poppler now, until it rebuilds not sure it will work...
    https://build.opensuse.org/package/s...:Tools/calibre

    Either raise a bug report about it of wait....
    openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    154

    Default Re: Calibre doesn't launch

    You need the two packages
    Code:
    libicu59_1
    libicu59_1-ledata
    poppler is not an issue any more.
    Both got replaced in the latest round of updates. They can still be found via the package search at https://software.opensuse.org/search
    But they are only available via a home repository from a user, so it is up to you if you want to take that risk or wait a couple of days.

    You can always install calibre via their webpage,
    https://calibre-ebook.com/download_linux

  4. #4

    Default Re: Calibre doesn't launch

    Thank you guys.
    I've already installed Calibre from their web, but I will be waiting for new updates.

  5. #5

    Default Re: Calibre doesn't launch

    I submitted a fix to the devel project to make it build again:
    https://build.opensuse.org/request/show/564005

  6. #6
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    154

    Default Re: Calibre doesn't launch

    Thank You.

  7. #7

    Default Re: Calibre doesn't launch

    AFAICS the updated package is in Tumbleweed meanwhile, so the standard version in the main TW repo should work again now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •