Hi,

I have a SAMBA share on an ASUS router. I mount this share at boot time with this entry in my /etcf/stab file
Code:
//192.168.0.1/sda1  /smb cifs username=guest,password="",vers=1.0
This has been working for months (possibly years!), but recently it has stopped working?
However, if I run (as root)
Code:
mount -a
The SAMBA shares are mounted perfectly?

Hunting through my logs for clues, I see this.

Code:
2017-10-16T22:28:40.021652+01:00 gzunder kernel: [ 1728.233524] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
2017-10-16T22:28:40.030786+01:00 gzunder kernel: [ 1728.242007] CIFS VFS: cifs_mount failed w/return code = -112
2017-10-16T22:32:22.350827+01:00 gzunder kernel: [ 1950.559850] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
2017-10-16T22:32:22.358861+01:00 gzunder kernel: [ 1950.565167] CIFS VFS: cifs_mount failed w/return code = -112
Relevant? It seems to be telling me to specify and option that is already set!

Regards, Martin
PS - running Tumbleweed 20180109