Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: how to start x.org without -nolisten tcp

  1. #1

    Default how to start x.org without -nolisten tcp

    I have changed every config, then I have also commented it out from every script. It still starts with -nolisten even after reboot. How do I remove that from the x.org invocation?

    This is blocking me in the lab from remotely debugging a 32GB application from a larger machine than my desktop. Due to technical reasons, ssh won't work.

    I'm about to pop a vnc session, and connect to that instead, which adds even more pain. o_O

    Also, why are there MULTIPLE points wrt to nolisten in opensuse scripts, NONE which have any affect?

  2. #2

    Default Re: how to start x.org without -nolisten tcp

    So Tumbleweed login manager is SDDM. Quick web search:

    > Not a developer of sddm, but a quick grep throught the sources for "nolisten" only finds on instance:
    >> src/daemon/XorgDisplayServer.cpp: << "-nolisten" << "tcp"

    Hard coded, nice. Guess I'll be doing a little binary editing today.

  3. #3

    Default Re: how to start x.org without -nolisten tcp

    Well it's not in the sddm binary either. Also, adding ServerArguments to /etc/sddm.conf has no effect. Neither does the yast2 tool.

    systemd? systemd.

    Other choice is to turn /usr/bin/X into a wrapper which strips the flag, and move X elsewhere, since systemd -> sddm -> X is a blackhole of information.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: how to start x.org without -nolisten tcp

    Hi
    Switch to lightDM?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: how to start x.org without -nolisten tcp

    I might as well switch distros then (I use the box for remote access mostly). I have a spare SSD here if I need to swap out and temporarily install a non-systemd distro in order to start X without -nolisten tcp

    # man sddm-helper
    No manual entry for sddm-helper
    #

    I'm surprised every single tip from google has failed so far.

  6. #6

    Default Re: how to start x.org without -nolisten tcp

    Somehow I failed to config this on install? Was it an option?

  7. #7

    Default Re: how to start x.org without -nolisten tcp

    I changed the dm with yast2, but it still uses SDDM after rebooting.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: how to start x.org without -nolisten tcp

    Quote Originally Posted by xorbe View Post
    I changed the dm with yast2, but it still uses SDDM after rebooting.
    Hi
    Isn't it a systemd service, so disable sddm and enable lightdm.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,705
    Blog Entries
    1

    Default Re: how to start x.org without -nolisten tcp

    Quote Originally Posted by xorbe View Post
    I changed the dm with yast2, but it still uses SDDM after rebooting.
    Not sure if this is current but...
    Tumbleweed selects the display manager through update-alternatives. To list all display managers the alternatives system knows about, run
    Code:
    sudo update-alternatives --list default-displaymanager
    To change the display manager
    Code:
    sudo update-alternatives --config default-displaymanager
    Reference:
    https://en.opensuse.org/SDB:Change_Display_Manager
    Last edited by deano_ferrari; 11-Jan-2018 at 23:38.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,705
    Blog Entries
    1

    Default Re: how to start x.org without -nolisten tcp

    Quote Originally Posted by xorbe View Post
    I changed the dm with yast2, but it still uses SDDM after rebooting.
    What is reported by the following?
    Code:
    grep -i "DISPLAYMANAGER" /etc/sysconfig/displaymanager

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •