Results 1 to 6 of 6

Thread: Can't boot after microcode update

  1. #1
    Join Date
    May 2012
    Posts
    29

    Default Can't boot after microcode update

    Hello forum,
    I am one of those guys whose computer fails to boot after updating intel's microcode.


    I am using: openSUSE Leap 42.2 (64 bit); KDE Plasma 5.8.6; Intel Core i3-4005U; Acer Aspire E15. Besides Suse, there are also installed Windows 8 (?) and Linux Mint 18 (Sarah), the bootloader is grub2 2.02-beta 94.3.1



    After last week's update my computer froze during the boot process with the kernel 4.4.104-18.44.1 default, stopping after showing the message "loading initial ramdisk". Booting with parameters nopt, nospec, dis_ucode_ldr, noefi wasn't successful either.



    Since my computer booted successfully with kernel 4.4.103-18.41.1, I didn't bother too much and just waited for the next update. However, after having just installed the new ucode-intel 20180108-7.12.1 the notebook still freezes when I want to boot with kernel 4.4.104



    Could it be helpful to re-install kernel 4.4.104? If yes, is there any special procedure required?



    Since an upgrade to Leap 42.3 is necessary anyway, would it be advisable to upgrade the current system or should I better make a fresh installation?


    It would be great if someone could give me tip what to do next in order to re-establish old functionality. If there are important information missing to solve the problem, I will give them as soon as I can. It would be useful if you could give me directions how to obtain them.

  2. #2
    Join Date
    Sep 2012
    Posts
    5,111

    Default Re: Can't boot after microcode update

    What CPU do you have? http://bugzilla.opensuse.org/show_bug.cgi?id=1074919

    If you have different CPU (family) - because Broadwell-E offending microcode should be retracted - by all means open another bug report, mention it on on the above bug report as well. Post number here for others to follow.

  3. #3
    Join Date
    Sep 2012
    Posts
    5,111

    Default Re: Can't boot after microcode update

    E-h-h ... but what makes you think it is microcode update? You say you can boot using older kernel and during update microcode is integrated in initrd of all installed kernels. You should check dmesg for microcode version.

    In any case you should open bug report, as there are quite a lot of issues with new patches.

  4. #4
    Join Date
    May 2012
    Posts
    29

    Default Re: Can't boot after microcode update

    That the microcode is the culprit was only a conjecture formed after reading in the forum. Following your advice I filled in filled in a bug-report
    https://bugzilla.opensuse.org/show_bug.cgi?id=1075732

    Thank you for your help.

  5. #5
    Join Date
    Sep 2012
    Posts
    5,111

    Default Re: Can't boot after microcode update

    Quote Originally Posted by tagg View Post
    Booting with parameters nopt
    It is actually "nopti". If you really used "nopt" it is worth to try the correct parameter.

  6. #6
    Join Date
    May 2012
    Posts
    29

    Default Re: Can't boot after microcode update

    You are right, but it was just a typo. This issue could gladly be resolved by installing a different kernel - see above bug-report.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •